Events + Marketpress Integration Not Working

I've searched for related threads, but can't find anyone reporting this same issue so I'm hoping I may just be missing something somewhere...

I've read he Usage instructions for Events+ integration with Marketpress, but can't seem to get that working. I activated the Marketpress add on in the Events settings. I then created a product to be associated with the event, and assigned it to the Events product category I had created. When creating the event, however, there is no option to select any product.

You will then see an additional dropdown menu in the Event Details when you create/edit an event where you can select the MarketPress product your event should be associated with as mentioned above.

This menu appears nowhere on the Event editor page. I have ruled out any plugin conflict, and tested using Twenty Sixteen theme with the same results.

Any suggestions are welcome. Support access has been granted on our dev install at kitchen.pieoneer.com if anyone cares to investigate further.

  • Nithin

    Hi jcnjr,

    I could replicate this issue in your website, unfortunately I'm not able to replicate this in my system. The issue seems to be odd, and specific to your website, I'm also aware of your MarketPress shortcode button issue too. The plugin conflict test doesn't show any difference, do you have any mu-plugins enabled, if yes, could you please rename the folder and check whether it works?

    If that didn't work, would you please send us your credentials so we can have a closer look?

    You can send credentials by using our secure contact form http://premium.wpmudev.org/contact/

    Select “I have a different question” for your topic.

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi jcnjr,

    Hope you are doing good today. :slight_smile:

    I have been going through your website, and I couldn't replicate this issue in any possible way in my system, it seems the issue with MP, and Events is only specific to this website. Even copied your entire core files, still it seems to work fine. Are you able to replicate this in any other websites? I checked further, and the only error encountered that could be related is:

    PHP Warning:  mysql_connect(): Can't connect to MySQL server on 'xxxxxx' (4) in /home/content/05/2571605/html/xxxwp-includes/wp-db.php on line 1520

    Could you please check, and confirm whether your DB_NAME, DB_USER, DB_PASSWORD, and DB_HOST entered in wp-config.php are correct.

    Please let us know how that goes. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi jcnjr,

    Just to let you know, the 'xxxx' is just a reference, it's the actual name of your database. This is the the only error that I could see which might cause some issue, you can find the error logs in wp-content/debug.log to check further

    Also, your folder, and file permissions are 705, and 604, default permissions are 755 and 644 respectively. Exception would wp-config.php which should be 440. I tried to replicate with your exact file permissions, but seems to work fine in my system. Not sure whether changing the permissions would make any difference, would like you to give a go. I do believe a new installation should also work fine, maybe some glitch with the server connection.

    I hope this helps. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin