events plugin hanging submit button, and not linking right

I posted an initial issue with plugin events and membership, but now found more issues with the events plugin so thought it will be best to start a new thread

1: WHen I click on add events from members section, the link works, but if I am on say a page site.com/about-us/ and click on add event from top bar, it automatically takes me to about-us/my-events/edit-event/ which is a wrong URL

see few seconds video http://screencast.com/t/4p8v1fwA0

2: when you submit an event as a member, the button hangs even if the event is posted. I saw this on an old thread and it got dismissed because the user was using single site but the issue is still on multisite as well . http://screencast.com/t/ldkJAaRX

3: posted this on another thread as part of an issue too. membership plugin blocks event from all members and non members except admin https://premium.wpmudev.org/forums/topic/membership-plugin-acting-weird-urgent#post-257990

  • aecnu

    Greetings edwardhadome,

    Thank you for these great questions and bringing these significant issues to our attention.

    1: WHen I click on add events from members section, the link works, but if I am on say a page site.com/about-us/ and click on add event from top bar, it automatically takes me to about-us/my-events/edit-event/ which is a wrong URL

    This is a very interesting issue, obviously you are running Buddy Press 1.5.7?

    2: when you submit an event as a member, the button hangs even if the event is posted. I saw this on an old thread and it got dismissed because the user was using single site but the issue is still on multisite as well

    You keep referring to "member". Does this mean you are running the Membership plugin as well?

    3: posted this on another thread as part of an issue too. membership plugin blocks event from all members and non members except admin

    My question above is obviously answered with this question. So lets find out exactly what we are working with here.

    WordPress 3.4.1?
    Obviously MultiSite
    Buddy Press 1.5.7?
    Membership 3.1.2?
    Events 1.3

    Please advise.

    Cheers, Joe

  • aecnu

    Greetings edwardhadome,

    Thank you for your quick reply and letting me know what we are working with there.

    Any chance you have already performed standard troubleshooting protocol on either of your mentioned networks having this issue?

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven theme just long enough to check for the problem - if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting. You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe

  • aecnu

    Greetings edwardhadome,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.