Events+ plugin is not displaying properly after the update

The Events+ plugin is not displaying properly. It broke a website so I started a new one using only the plugin.
The calendar displays vertical-align centered instead of a top. See: https://dekalbcountyevents.com/events
The hover only shows the date or time no excerpt or description.
Was working fine until an update.

  • Predrag Dubajic

    Hi Mac McIntyre,

    I did another test with the beta version on my installation but I can't replicate the issue, here's an example with both excerpt and image showing:

    Then I tested this on your site by creating WPMU TEST page (it's set as private) with the calendar shortcode, and then I created a test event (I've removed it after testing) and everything seems to be working well there:

    What I noticed with your current events is that they don't have featured image assigned so there's nothing to display, and beginning of your event content is same as your title and that's what's shown as excerpt.

    Can you try creating one event with featured image assigned and content being different from title and check if you can see everything properly after that?

    Best regards,
    Predrag

  • Mac McIntyre

    Thanks. I don't know what happened to the featured images or map data for that matter except that the paths are gone. I use the plugin on several websites and this one is unique. On other sites on an update the calendars reverted to an incorrect year. They also conflicted with the User Submitted Post plugin (as did other plugins) following an update from its developers. This broke several of the sites so I created this one using data from a production site that broke. We may not be able to fix past events but on newly entered ones according to your test looks like they will display properly.

  • Predrag Dubajic

    Hi Mac McIntyre,

    I don't know what happened to the featured images or map data for that matter except that the paths are gone. I use the plugin on several websites and this one is unique.

    So you had featured images assigned before but they are no longer assigned, is that correct?
    Did this happen after you have updated Events+ plugin or User Submitted Post?

    On other sites on an update the calendars reverted to an incorrect year.

    I'm not sure that I understand this completely, could you provide some more information?
    Is calendar shortcode showing incorrect year on page load?
    Could you share a link where we can see this in action?

    This broke several of the sites so I created this one using data from a production site that broke. We may not be able to fix past events but on newly entered ones according to your test looks like they will display properly.

    What happens if you go to old event and re-attach featured image, does it save and show properly on calendar?

    Best regards,
    Predrag

  • Mac McIntyre

    So you had featured images assigned before but they are no longer assigned, is that correct?
    Did this happen after you have updated Events+ plugin or User Submitted Post?

    I administer more than a hundred websites and use one dashboard to update plugins and themes. I update on a daily basis. So I don't know in what order the updates were. On broken sites I found the conflict through trial and error, turning plugins off and on until I found it - User Submitted Posts.

    On several websites an update of Events+ resulted in the default /events page to display a calendar with the current month but in the year 4400 resulting in a blank calendar since no event data was entered for 4400.

    On dekalbcountyonline.com the calendar was 4400 and the User Submitted Post conflict resulted in the website display shortcodes instead of actual content. That is a production site, several hundred thousand calendar pageviews per month and is large site with too many plugins. It is advertising supported. The resource demand from Events+ was too high and with the site broken I created dekalbcountyevents.com and moved the Events+ calendar there to reduce stress and get the calendar to display properly.

    The beta version you provided improved the display to an acceptable level to get back in business. However this morning the default /events page was displaying the year 1200. Mondays is a big traffic day so I reverted the plugin to the latest one available on WPMU and it is displaying the year 4400. The RSS feed is displaying properly from dekalbcountyevents to dekalbcountyonline but it is not making advertisers happy.

  • Predrag Dubajic

    Hi Mac McIntyre,

    I checked the current live version (1.9.7) on my end and I could indeed see the 4400 year issue and was able to get it working by adding date="now" attribute to calendar shortcode.
    I then updated to 1.9.8 beta and when removing that attribute the year was correct.

    On your site, is the year showing 1200 with 1.9.7 or 1.9.8 beta?
    Could you give me an URL where I can see this and grant support access to that site?

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.