Events + plugin missing/lost events.

Hi,

We just encountered a strange issue that was flagged by our client. It looks like a number of events--more than 5--disappeared. They longer appeared under the "Events -> Events" menu in the admin Dashboard, and were no longer visible on the frontend of the site.

We were able to recover the posts by importing them through an XML export from a previous Db backup, but this is a bit of a perplexing issue.

We'd like to know if there are any other cases were event posts disappeared from the admin/front end since this was an alarming issue for the client.

Thanks

  • Adam Czajczyk

    Hello artsygeek,

    I hope you're well today and thank you for your question!

    Could you please tell me a bit more about the issue? As you said

    They longer appeared under the "Events -> Events" menu in the admin Dashboard, and were no longer visible on the frontend of the site.

    However, were they visible in dashboard all the time or did disappear also at some point? Were those active or already passed (past) events? By "front-end" are you referring to a regular "events list" page or to an events widget in sidebar?

    We were able to recover the posts by importing them through an XML export from a previous Db backup, but this is a bit of a perplexing issue.

    I understand that this brought missing events back. Are there now duplicated events in your dashboard as well?

    Please advise!

    It would be also great if you could grant me a support access to your site so I could take a closer look. You could do this by following this guide:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam