Events Plugin Warning Message

When I am using trace and debug I was getting warning errors related to Events +. It was flagging events-and-bookings.php line 153 saying that 'post-type' was an invalid index. This would happen before logging in to my site when I went to a front-end login page.
I fixed the problem by adding a test before line 153. Here is the code:
` public function reverse_m2_modified_event_cpt( $wp_query, $obj )
{
if( isset( $wp_query->query_vars['post_type'] ) ) {
if( is_array( $wp_query->query_vars['post_type'] ) && $wp_query->query_vars['post_type'][0] == Eab_EventModel::stuck_out_tongue:OST_TYPE )
{
$wp_query->query_vars['post_type'] = Eab_EventModel::stuck_out_tongue:OST_TYPE;
}
}
}`
If you could have the developer add that, I would appreciate it. I know it's just a warning message, but I like my code to run clean.

Thanks!
Richard