Events + settings page is not complete

I`m trying to sett up the Events + plugin, but the whole settings page is not coming up, so I cant´t get all settings done.

I have tried disableing all plugins (except events +) but no change. Tried both in chrome and firefox. Run WP 3.9.2 on theme Divi 2.1.1 from Elegant Themes, server run on php 5.5 Here´s a screenshot of the settings page as I see it.

  • aristath
    • Recruit

    Hello again @hakonzen,

    I tried with the 2012 theme, and it was the same with that theme

    That’s weird…

    Could you please grant me access to your backend so that I may see exactly what is happening?

    To do so, from your dashboard go to WPMUDEV => Support => Support Access and click on the “Grant access” button.

    Cheers,

    Ari.

  • Tyler Postle
    • CGO

    Hey Hakonzen,

    My apologies for the delay here! My colleague, Ari, has recently moved and is still waiting for his internet to get setup. He’s been relying on cafe wifi’s :p

    Do you mind re-granting support access? I’ll keep an eye out for your response so we can get this resolved asap for you :slight_smile:

    Cheers,

    Tyler

  • Hakonzen
    • Site Builder, Child of Zeus

    Hi there Tyler, and thanks for filling in for Ari while he´s on the move.

    I have re-granted the access, and hope you can find out whats going on.

    I have tried disableing all plugins (except events +) but no change. Tried both in chrome and firefox. Run WP 3.9.2 on theme Divi 2.1.1 from Elegant Themes. Divi uses a builder, maybe that´s causing the problems?

  • Tyler Postle
    • CGO

    Hey Hakonzen,

    Good to hear back from you. No problem, happy to help :slight_smile:

    I see the issue, and you mention that even with all plugins deactivated and in the default 2012 theme the issue was still persisting?

    Can you try deleting the Events+ plugin then re-installing it through the WPMU DEV dashboard? Be sure to temporarily deactivate WP Rocket too, as caching plugins can sometimes cause issues like this.

    If that still doesn’t resolve anything, would you mind sending in your FTP credentials? Then I can take a closer look at the files and run a debug test.

    You send that info through our private contact form:

    https://premium.wpmudev.org/contact/

    Send in:

    Subject: “Attn: Tyler Postle

    -WordPress admin username

    -WordPress admin password

    -login url

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant urls

    Select “I have a different question” for your topic – this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Since we have support access, you don’t need to Send in the WP credentials, you still can just in-case the access expires though.

    Look forward to hearing back!

    Cheers,

    Tyler

  • Tyler Postle
    • CGO

    Hey Frode,

    Thanks for sending that info in :slight_smile:

    I notice you have a ton of extra code in your .htaccess. Did you put any of that there on purpose or is it just left over from past plugins? I can tell some of it is from WP Rocket.

    I would make a copy of that, then delete it and go to your Settings > Permalinks.

    re-save your permalinks, and that will create a fresh .htacess file. Then try accessing your Events settings :slight_smile:

    If you run into any issues after deleting your .htaccess, you can just send back over your saved copy.

    Let us know if this does the trick!

    Cheers,

    Tyler

  • Hakonzen
    • Site Builder, Child of Zeus

    Hi Tyler

    I have not been altering the .htaccess files, so this has to be done by plugins automatically. I use the MainWP (http://mainwp.com/) on the site, but it´s currently disabeled. That might be the reason for the extra code there.

    I will try out your suggestions tomorrow morning over a fresh brewed pot of coffee and see if that does the trick

    Thanks a lot for your input, I will keep you posted after the caffeine shock :slight_smile:

    Best regards

    Frode

  • Tyler Postle
    • CGO

    Hey Frode,

    That could be, I did see some references to MainWP in there as well.

    Sounds good Frode! :slight_smile:

    I’m actually just heading to bed myself, so I will check back in on this tomorrow morning as well, once I’ve got some caffeine in me :p

    Talk to you soon.

    All the best,

    Tyler

  • Hakonzen
    • Site Builder, Child of Zeus

    Hi again @tyler

    I have now deleted the .htaccess (and .htaccess.orig that was there also) after taking a copy of them

    Then I resaved my permalink settings, and tried the Events+ plugin again, and there´s no change sadly :slight_frown:

    As I mentioned, I use the MainWP plugin and WP-Rocket plugin, but both are disableled now, but they probably add stuff to the .htaccess file.

    I also run this site throu Cloudflare. I don´t know if that makes any difference in this case.

    I really should have the Events+ up and running now, so I hope you or someone else have some valuable insight on this issue

    Thanks

    Frode

  • Tyler Postle
    • CGO

    Hey There Frode,

    Thanks for the update :slight_smile:

    After further investigation, I think I found the problem error:

    23-Aug-2014 08:23:50] PHP Fatal error: Call to undefined function escape() in /home/2/v/vanvuuren/www/fotokursene/wp-content/plugins/events-and-bookings/lib/plugins/eab-rsvps-additional_registration_fields.php on line 198

    Looks like the additional fields add-on is causing the issue here.

    Can you take a look at Vinod’s post here: https://premium.wpmudev.org/forums/topic/problems-with-events-installation#post-642102

    He assisted someone with a similar issue recently. After testing that out, let us know if ASP tags were the issue or not.

    If not, then we’ll look at other possibilities :slight_smile: thanks for all your patience here!

    Cheers,

    Tyler

  • Hakonzen
    • Site Builder, Child of Zeus

    Hi Tyler

    Thanks for the investigation

    I have now put the `<% echo ‘You may optionally use ASP-style tags’; %>

    <%= ‘This is a shortcut’; %>

    into the footer.php like this:

    <?php if ( 'on' == et_get_option( 'divi_back_to_top', 'false' ) ) : ?>
    <% echo 'You may optionally use ASP-style tags'; %>
    <%= 'This is a shortcut'; %>
    <span class="et_pb_scroll_top et-pb-icon"></span>

    <?php endif;
    to see if anything happend. As you can see, nothing was outputted in the footer http://www.fotokursene.no/kurskalenderen/

    I

    m not a code savvy guy, so I don´t know if I did this the right way?

    Cheers

    Frode

  • Tyler Postle
    • CGO

    Hey Hakonzen,

    It looks like you entered in correctly there, I don’t see anything showing up on the frontend.

    Who’s your host?

    For some reason your site doesn’t seem to like the additional fields add-on.

    I deleted that add-on file from your Events+ directory and everything is back to normal. Aside from the add-on not being there of course.

    Can you check it on your end and make sure it’s working correctly?

    Cheers,

    Tyler

  • Hakonzen
    • Site Builder, Child of Zeus

    Ok, I can se the whole settings page in Events+ now, great, Tyler!

    Forgive my ignorance, but what is the add-on file you are talking about, and what I`m I missing out on having that deleted?

    The host for this site is; http://www.domainnameshop.com

    (a shitty shared hosting provider if you ask me, but what the costumer wants…:wink:

    And what about the `<% echo ‘You may optionally use ASP-style tags’; %>

    <%= ‘This is a shortcut’; %>

    shall I remove this from the footer.php now?

  • Tyler Postle
    • CGO

    Hey Hakonzen,

    The add-on file I deleted was located:

    wp-content/plugins/events-and-bookings/lib/plugins/eab-rsvps-additional_registration_fields.php

    It was the additional registration fields add-on that was causing the issues in your install. Once removed, everything worked fine :slight_smile:

    What you’ll be missing now, is the ability to create additional registration fields if a person signs up for your site through the Events page.

    And what about the `<% echo ‘You may optionally use ASP-style tags’; %>

    <%= ‘This is a shortcut’; %>

    shall I remove this from the footer.php now?

    Yes, you can go ahead and remove that :slight_smile: thanks for testing that.

    The only reason I can think of why the error happened in the first place is server related. A server configuration that didn’t like that add-on. You could bring it up with your host as well.

    Let me know if you have any further questions :slight_smile:

    Cheers,

    Tyler

  • Hakonzen
    • Site Builder, Child of Zeus

    Hi again Tyler

    Have removed the tags in the footter now, and now I will start setting up the events page and let the customer add events. Hopefully everything will go smooth from here :slight_smile:

    I will send a message to the hosting company, asking them about the issue, but I don´t have much hope in getting a useful respond thou

    >I`m now testing out Siteground.com on some sites, and it´s looking very promising. Optimized for WP and superb service!

    Thank you very much for your help, Taylor, you have been most helpful!

    And @Aristaht, hope you are well setteled son and have your wi-fi (lifeline) up and running, thakns to you too!

    Have a great saturday night!

    Best regards

    Frode

  • Tyler Postle
    • CGO

    No problem at all Frode :slight_smile:

    Glad we got this sorted!

    Superb service is crucial when it comes to web hosts, last thing you want to do is spend all your time trying to resolve server issues :p

    Saturday morning for me, I’m actually in Canada – our support team is very distributed. Ari is in Greece. Anyways, you have a great Saturday night as well!

    All the best,

    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.