[Events +] Translation Support for Events+

I installed Events+ on a website using the plugin "WPML Multilingual CMS." After having some difficulties getting it started up, I contacted support and was informed that Events+ is just not compatible with "WPML Multilingual CMS."

Thanks.
Paul.