Ever since the update after 2.9.6.2 my product pages would

Ever since the update after 2.9.6.2 my product pages would deliver an "Ooops Page Not Found" error.

I have one product on my swatchright.com website. I have several over at thelandofcolor.com

So, what I've been doing is testing the MarketPress updates on swatchright.com with just one product to see if this new problem with the error page popping up corrected itself. (I still have v 2.9.6.2 installed over at The Land of Color.)

It has not corrected itself. So, I got into the swatchright.com website today to try to figure out how to fix my product pages so they show up as "normal" like they did in v 2.9.6.2.

I checked a box that came with a "this is permanent" warning. Don't remember exactly what it said, something with wp_content - maybe.

It seemed to fix the"Ooops Page Not Found" error but now all the files are gone of past orders. When I go to my Order page in MarketPress this is what it looks like now. How do I fix this issue? And of a bigger scope, how do I make the newest update work with regards to the existing product pages over at The LoC?

Thanks.

  • Rupok

    Hi lori_sawaya7

    I hope you had a wonderful day.

    Can you make a plugin test to make sure this is not happening for a plugin conflict? This is very unusual. You can know more about plugin test from here: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Can you turn on the debug mode in WordPress and try to switch users few times to generate errors? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If file is very long, please paste them to a text file and attach with your reply.

    Moreover, would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!
    Rupok

  • lori_sawaya7

    I don't use that many plugins so I deactivated and reactivated each - did it on both websites, thelandofcolor.com and swatchright.com. The plugins are not the issue.

    The issue seems to be that this version of Market Press does not work with The 7 WordPress theme I use. Here's a link to the theme http://goo.gl/Z1E8Uk.

    Decided to install the update over at thelandofcolor.com as well as on swatchright.com. I did have to tweak a few of the products pages, but that issue seems to have resolved itself with the deactivation/reactivation of plugins - on both sites. The product pages links and shopping cart all seem to be working well.

    So, now the problems remaining are this version of MarketPress makes my theme look wonky AND the "Orders" paged in MarketPress doesn't look like it used to as I mentioned before. Again, all the previous orders do not appear. But I have a feeling that this has something to do with MarketPress being incompatible with my theme, The 7, from Envato Market.

    Debug.log attached in next post. Hope this leads us to a solution to get my theme and the newest MarketPress to work together. Thank you.

  • lori_sawaya7

    Hi Kasia,

    No worries about the delay. I have this 50% fixed. Part of the problem was fixed by installing the new version of The 7 theme that was released this week - with some tweaking, I got page titles to look like they are supposed to. So, we're down to just one issue and it is specifically a Market Press issue.

    I granted you access. Go to thelandofcolor.com > Store > Orders. You'll immediately see that the table doesn't look right. I have info from over 300 past orders stored in the Market Press database yet you only see the last two orders.

    Thanks.

  • lori_sawaya7

    Few more things:

    1. When you click on the one past order that you can see, you get a "server error" page.
    2. Shipping Info > Actual Shipping Method: there is no longer an option for USPS (United States Postal Service). Can you please add that option back in? I would think a majority of folks using MarketPress is using USPS either partially or entirely. I, for example, ship via USPS exclusively.

    Have to say, the older version of Market Press handled specifying how product was shipped, adding tracking info, and then automatically updating the status to "shipped" much better than this new version. Looks like with the new version, after I enter shipping method and tracking, I have to physically go mark the product/order as shipped. An extra step we didn't have to take in the old version.

  • Kasia Swiderska

    Hello Lori,

    So this error crashes page of orders. I would like to replicate it, but because I can't edit order can you tell me what kind of products where ordered in this particular order? Digital or normal (that you have to send) - or maybe both? There should be email with the order. On my testing site this works fine - so maybe there is some combination that needs to be triggered.
    Alternatively you could try solution from here https://premium.wpmudev.org/forums/topic/order-admin-detail-page-is-blank#post-992826 (I know that other member claim that is still not working, but maybe it will show us the list or allow to edit order) - but before this step please be sure you have backup of your site.

    kind regards
    Kasia

  • lori_sawaya7

    Did you go to my WP Dashboard > Store > Orders and look at the table? I granted access.

    I also provided a screen shot. What is there to replicate? It's all right there for you to see.

    That fact that works fine on your testing site doesn't really help my situation does it?

    In summary, the new version changed the permalinks to all products which means all previous links broke and there is something fundamentally wrong with how Market Press is handling the database for past orders.

    I'll take a look at the link but you need to reconcile with the fact that the new version of MarketPress has issues that need to be fixed. I really don't want to have to switch to WooCommerce but I'm about ready to do so because it's the ecommerce option the theme I use recommends.

  • lori_sawaya7

    What triggers this error is the newest update of MarketPress.

    To replicate my issue:
    1. Go back in time to 2012
    2. Buy and Install MarketPress on your Website
    3. Load it with product
    4. Use the plugin for three years to sell product and build up a customer database
    5. When 2015 rolls around, install the new MarketPress Update
    6. Waste a crap load of time and energy dealing with the changed permalinks and resulting broken links, and disabled Order tracking function.

  • Rupok

    Hi Lori

    I hope you had a wonderful day. I'm so sorry for the inconvenience you have had.

    # "That fact that works fine on your testing site doesn't really help my situation does it?" You are absolutely right. This doesn't solve your issue, but this helps us to be confirmed that it's not a bug of our plugin, rather something at your site is not working properly. So now we can move our full focus on your site.

    # You said "The product pages links and shopping cart all seem to be working well", so this issue is done.

    # Then you said "this version of MarketPress makes my theme look wonky AND the "Orders" paged in MarketPress doesn't look like it used to as I mentioned before." and it seems like it's done also as you said "Part of the problem was fixed by installing the new version of The 7 theme that was released this week - with some tweaking, I got page titles to look like they are supposed to".

    # I logged in http://thelandofcolor.com site and went to Orders page, but I see no fatal error there. Please check the attached screenshot. There is a design issue - the status column is too narrow and it's not showing the editing links properly. However, you can easily fix it with our "Ultimate Branding" plugin. After installing this plugin, go to "Dashboard > Branding > Branding" and you will see lots of add-ons. Enable "Custom Admin CSS". Then use the following custom CSS code. It will beautify your Orders table.

    .widefat .column-mp_orders_items, .widefat .column-mp_orders_status {
      text-align: left !important;
      width: 170px !important;
    }

    Have a nice day. Cheers!
    Rupok

  • Jose

    Hi Lori,

    There is an issue with orders created in MP versions previous to 3.0.

    A fix will be released soon. In the meantime, you can solve this by changing the line 1076 in
    wp-content/plugins/marketpress/includes/admin/class-mp-orders-admin.php
    from this:
    $cart = $order->get_meta( 'mp_cart_info' );
    to this:
    $cart = $order->get_cart();

    Please let us know if you need help implementing this change.

    Cheers,
    José

  • soundconcept

    update: there are four instances which need to be replaced in that file. Here are the ones I found, with line numbers:

    305: $cart = $order->get_meta( 'mp_cart_info' );
    324: $cart = $order->get_meta( 'mp_cart_info' );
    488: $cart = $order->get_meta( 'mp_cart_info' );
    1076: $cart = $order->get_meta( 'mp_cart_info' );

    My line numbers may be a little off, but they are close!

    A real update would be most welcome!

  • Tyler Postle

    Hey Soundconcept,

    One of our developers has fixed the file so I don't believe the other edits will be necessary, would you mind trying it out to see if it resolves the issue for you? If it does then we'll be pushing the update shortly :slight_smile:

    Save a copy of your current class-mp-orders-admin.php file just in-case.

    To test out the fix, just unzip the attached folder and overwrite your current class-mp-orders-admin.php file.

    Sorry for such a wait on this!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.