Ex- and Import media files

Hi there,
I'm experimenting and learning a bit about exporting sites form a MS network to a WP standalone install. I have done this before, and then the importing of the media files in the library went smooth.
Not this time. They are NOT imported. Only a plugin like 'Add from server' works, but it's a lot of clicking work...
I wonder: what can be an explanation?
Can it have to do with the webhost or server settings?

Just wondering and hoping to learn.

Thanks for thinking with me!

  • Luís
    • Support

    Hi Ronald ,

    Hope you're doing well today!

    It could be related to the server settings, specially to the "memory_limit" or "max_execution_time" variables.

    However, it's just a supposition, it's bit hard to give an explanation without more informations. The best option in this type of situations is enable the debug flags in the "wp-config.php" file, to check which errors are being saved, it can help us identifying what is going on:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    It will be saved to a debug.log file inside the "wp-content" folder. Can you share it with us?

    https://codex.wordpress.org/Debugging_in_WordPress

    Note: Save the file as a .txt, because the .log extension is not allowed in the attachments.

    Cheers, Luís

  • Ronald
    • The Crimson Coder

    Hi Luis,
    Thx for helping!!
    I did a fresh WP standalone install and an import (see screenshot, which I get to see after a few seconds, so a time-out doesn't seem plausible...), with the wp-config.php rules you described, and renamed the with .txt in the end.
    Please see attachment, I hope you can make something of it...
    (I'm in no hurry, so please enjoy your sunday first!)

  • Ash
    • WordPress Hacker

    Hello Ronald

    Can it have to do with the webhost or server settings?

    Yes, I guess so. In some webhost/server there is limitation to send a number remote request to a server. Most of the time shared server has this sort of limitation. Another issue could be, one media file is too big so it can't be remotely transferable.

    I would suggest to import in a test site which must be installed in an old server where you have already imported successfully again. So that we can be sure if it is server related issue or something else.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • Ronald
    • The Crimson Coder

    OK Ash, thx for responding.
    I know it worked on my present server. Not on my new server. File size and number can IMHO not be the cause, because the test I did on the new server was with a limited number of media files (less than 200) and max. file sizes of 6 MB (a few PDF's).

    Can you give me a hint what I should ask the webhost / in which directions the involved server settings are to be found?

    Thx in advance!!

  • Luís
    • Support

    Hi Ronald ,

    Hope you're doing well today!

    Looking for the PHP info file I am not finding anything that could explain the issue, but I am not a server expert.

    Have you checked if the "wp-content" and "wp-content/uploads" folders have the proper permission settings? Those folder should have "755".

    https://codex.wordpress.org/Changing_File_Permissions

    Also, if you don't have access, ask to your host provider for the server error log, it can have an additional information that can be helpful.

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.