exceptions (non/ workingdays) has no calendar as service provider

hello,
When logged in as a service provider, then all exceptions for working and non-working days need manual input using YYYY-MM-DD.
When logged in as admin, it shows a great datepicker for this that automatically enters these days.
Can this also please work for service providers?
(can i change this manually somewhere?)

  • aristath
    • Recruit

    I'm afraid I'll have to take a closer look at your site to figure out what exactly is going on...

    Can you send me your admin credentials please?

    - Send an email using our secure contact form on https://premium.wpmudev.org/contact/
    - Select "I have a different question" from the dropdown
    - On the subject enter "Attn: aristath".
    - Include the URL of this post in your message so that I may track this issue
    - Include a link to your website
    - Include your superadmin credentials (username + password)

    Cheers,
    Ari.

  • Hypnosecentrum
    • WPMU DEV Initiate

    thanks aristath. if you dont mind changing your hosts file? (its not replacing the current domain name)

    But actually my question is simple, if you confirm with a yes, then its a
    new feature request, if not, then please let me know how.
    the question is:
    When logged in the backend as superadmin, and go
    to appointmentsplus->Settings->Exceptions, then when i click
    in a field for a exceptions, i get a nice datepicker.
    When i log in the backend as Service Provider and go to my profile,
    i also have the exceptions fields (and holidays field), but NO datepicker :slight_frown:

    Is this correct?

  • aristath
    • Recruit

    The reason I asked for your admin credentials is so that I could check for any Javascript conflicts using Chrome developer tools.
    On my test site I did not encounter this issue, so this could be because of a conflict with a script loaded from a theme or plugin in your Dashboard...

    If you can test it yourself it's fine. This is what I'll need you to check:

    Just open that page using your admin account and using Crome, press Ctrl+Shift+J.
    On an incognito session on Chrome, login using the account that has the issue and press again Ctrl+Shift+J.
    Compare any errors between these 2 and let me know if there are any errors on the account that does not display the datepicker.

    Cheers,
    Ari.

  • aristath
    • Recruit

    @Hypnosecentrum

    So, you ARE saying the calender shoudl also standard popup in the profile page for a service provider, right?

    Well, it depends... I'm trying to replicate your issue.
    What user role do your service providers have?
    Are they trying to change these on their profile, or someplace else?

    Please advise,
    Ari.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi, Amanda!

    I'm not able to replicate it on my test site, I'm guessing this is a javascript conflict between the datepicker and another plugin you might be running. Can you do a quick test to see if that might be the case?

    Is your issue the same as the above - admins are able to use the datepicker, but users with a non-admin role who are also service providers do not see the date-picker on their profiles when setting their own hours?

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.