Excessive resource usage / high load

Hello!

I'm looking for your input on reducing some excessive load I have with a website of mine. Currently I'm using Hummingbird but my question is, will this do enough for caching? Can you have a look into my current set of plug-ins and maybe make a recommendation or replacement plugins you suggest from wpmudev that may be more efficient?

I currently use humming bird, defender, smusher and analytics... This website already had a barrage of other plug-ins that I need to be able to work with or change out with ones that are more efficient. Suggestions/advice?

Thanks!

    Adam Czajczyk

    Hello Rob,

    I hope you're well today and thank you for your question!

    I have visited your site (front end) and I can confirm that it loaded extremely slow for me. I wasn't also able to access it via support access that you granted - most likely due to such a long loading time. Furthermore (which I admit is quite surprising) "Waterfall" test tool from Pingdom wasn't also able to load the page, timing out after 60 seconds.

    However, when loading the site with browser I was able to see it even though the "loading wheel" kept spinning - the site was rendered. That being said, I'd suspect that there are some "resource blocking" (or "infinite looping" scripts that are causing this. Since I wasn't able to access your site via support access I'd like to take a more direct approach. Could you please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account)
    - Include FTP log-in details (hostname, username & password, port if non-standard)
    - Include hosting control panel access details (login address, username & password)
    -- cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site and any additional information that you consider relevant to the issue

    Please use our contact form here https://premium.wpmudev.org/contact/.
    Select "I have a different question" from the drop-down list.

    Please be sure to make a full backup of your entire site first!

    Best regards,
    Adam

    Adam Czajczyk

    Hello Rob!

    I got your message and I was able to access and review your site. Here are some conclusions that should help you speed up the site and decrease resource load:

    1. I'd start with replacing the WCP Open Weather plugin with either some other weather plugin (you may need to test a few) or with an "embed" code from a weather service included directly in page template file. This seems to be a big resource eater and also its Google Maps API is causing an error: the GMaps scripts called by this plugin doesn't seem to be available so while browser is trying to load them but is not able to - it's increasing loading time.

    2. There are two calls to FontAwesome font files which doesn't exist. I'm not sure whether these are used by some plugin or by the theme but again - attempt to load non-existing file from server is a classic case of "rendering blocking". The simplest way to fix it would be to provide the site with these files. They should be located inside /wp-content/uploads/fonts folder and you may easy identify them by running tools.pingdiom.com test on the site (it seems to be working fine now).

    According to this test switching off weather plugin alone speeds up the page load by almost 8 seconds!

    2. There are 21 Jetpack's modules active on the site. I took a brief look at them and I'm pretty sure a significant number of them could be disabled. I'm not that familiar with your site to decide which ones should that be but I'd suggest reviewing them and disabling as many as possible.

    3. I can see that WP Smush Pro is active and images are optimized, also Browser Caching and Gzip compression are enabled with Hummingbird. Minification is also enabled and I see that you have already "played" with it a bit to set it up. Therefore there's nothing more to be done here in my opinion.

    4. I'd go for an additional caching plugin such as for example W3 Total Cache or Wordfence (just for caching). This should have some impact especially given the fact that there's also quite a long server response time, which leads me to the next point:

    5. The server response time is slowing down site load and may be caused by what is an initial issue here: excessive resource usage. Therefore first task would be to implement suggestions listed above and then examine resource usage again. Then you may want to optimize Apache and mySql server settings on your server.

    These latter tasks would be quite complex and may require some "trial and error" attempts. If you feel like you could give it a try yourself, here are some useful resources:

    http://www.jeffgeerling.com/blog/3-small-tweaks-make-apache-fly

    http://httpd.apache.org/docs/current/misc/perf-tuning.html

    https://www.digitalocean.com/community/tutorials/how-to-optimize-apache-web-server-performance

    https://dev.mysql.com/doc/refman/5.5/en/optimizing-the-server.html

    https://www.percona.com/blog/2014/01/28/10-mysql-performance-tuning-settings-after-installation/

    http://www.debianhelp.co.uk/mysqlperformance.htm

    In case you'd need some professional help with optimizing these settings (Apache and mySql) you may also want to post a question about it on our "Jobs & Pros" job board (please note: no WPMU DEV staff involved!) here:

    https://premium.wpmudev.org/wordpress-development/

    I hope that helps!
    Best regards,
    Adam

    PS. You may notice that the "WPMU DEV" item is gone from your admin menu. The plugin is active so in order to "get it back" please go to "Plugins -> All plugins" (while being logged-in to your admin account) and de-activate it and then enable it back.