Experiencing some issues with Avatar. The image uploads

Experiencing some issues with Avatar. The image uploads and goes immediately to crop. After clicking crop, the image disappears. If I try Alt Upload, I just get a blank page with "There was an error uploading the file, please try again."

Not getting any useful errors messages like "___ not installed". (Guessing that there is some server component that is missing, although regular uploads work fine.)

  • peter_harris
    • Syntax Hero

    I did the easyengine install with W3TC but it's currently disabled. (Unfortunately I lost the note you gave me about using fastcache instead... want to ask a separate question about that later.) Also no CDN or security plugins.

    Only things close to that are Anti-Splog and the Nginx helper plugin from RTCamp.

  • peter_harris
    • Syntax Hero

    Hi Michelle,

    You're right that I'm trying to transition from WP User Avatar to yours. However, I had disabled that plugin before trying to use yours, so it wasn't in use when I ran into the problems I described. Until I find out the source of the difficulty, I need to leave that old one activated. Any other ideas about what could be causing those errors?

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi Peter,

    Okay, troubleshooting with both plugins active may prove to be a little difficult. I see WP User is only active at the individual blog level, not Network Activated, so we might be able to work around this.

    First thing I'm seeing, WP User Avatar instructed you to drop in this short code:

    Use the [avatar_upload] shortcode to add a standalone uploader to a front page or widget.

    If you dropped this in on any of your pages, can you either temporarily remove it or comment it out and see if you can upload with Avatars?

    Thanks!

  • peter_harris
    • Syntax Hero

    Hi Michelle,

    I wasn't using that shortcode, but not sure why that would matter if I had disabled the plugin when testing yours? Or could that somehow still have an effect?

    Would be happy to do a test with you to disable the old plugin so you can log in to my site and test it, but would want to coordinate the timing of that in advance so that I don't leave it off for hours. (There is a page showing a bunch of members and when I disable the old plugin, most of the avatars disappear.)

  • Tyler Postle
    • CGO

    Hey Peter,

    Hope you're doing well today!

    You may have noticed I just made a test account - hope you don't mind. Just wanted to see the issue first hand, you can delete that now if you like.

    In notice you still have "purge cache" in your admin bar, do you have another caching plugin enabled or somewhere else on your setup?

    Have you already tried turning of all other plugins to ensure no other plugins are causing any conflicts? This would be easiest through FTP by temporarily re-naming the plugin folder then creating a new 'plugins' folder and only having the avatar plugin in it.

    Once you re-name the previous plugins folder back to 'plugins' everything will be re-activated again :slight_smile: it's sort of a soft-deactivate technique. Just don't visit your Admin plugin page while they are all soft-deactivated otherwise it will fully deactivate them.

    Let us know if that narrows down the issue at all here!

    Look forward to hearing back.

    Cheers,
    Tyler

  • peter_harris
    • Syntax Hero

    Hey Tyler, disabled all plugins and didn't solve the problem, so I thought I should look at the issue from another angle -- I have been assuming that image editing was working since I moved to nginx (as I can do uploads fine and the system generates thumbnails). But there it is... I can't crop images. And that is the step that's always failing with the avatar plugin.

    If you go in to the media library and try to crop an image, you can select the cropping area, but the crop tool stays disabled. What's stranger still is that the 'thumbnail settings' box doesn't even appear.

    So it looks like I have some configuration issues related to my nginx setup and nothing to do with the avatar plugin itself!

    Maybe I should start a separate thread about this since its obviously a totally different issue?

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi, Peter!

    Thanks for doing that!

    I've checked Avatars in my own network, and I'm not able to replicate your issue on any of my subsites, but I can on yours. (Also, Tyler now has an angry unicorn avatar. Shh.) Since you've tried disabling other plugins and are still seeing the issue, there's a chance this is a theme conflict. I notice you have a wide array of network activated themes, is this issue consistent on subsites with different themes, by chance? And are any of those themes the WordPress defaults? (twentyfourteen, twentythirteen, etc.)

    Let me know! We'll get this figured out.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi, peter!

    A theme conflict was the last issue I knew of to check. I've gone ahead and installed Avatars on two more sites, and chatted with my teammates, and we're seeing everything act okay on our own sites.

    Let's take this a little deeper, if it's okay for me to take a peek at your site via FTP could you use the contact form to do the following:

    Subject: "Attn: Michelle Shull"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Thanks!

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi Peter, sorry for the delay.

    I've run a series of tests on my own site, trying to match your configuration the best I can, and the only way I've been able to make it work is somewhat of a nuclear option. Now that I've given you the cold sweats, it's not a terrible nuclear option, just a slightly scary one.

    I was never able to make Avatars' crop function work as long as Member Avatars was also installed. So, I uninstalled our plugin, loaded up my dummy user list with Plugins using the alternate plugin, then reinstalled ours. As soon as I deleted (not just deactivated) the other pluglin, Avatars worked flawlessly, and it used the previously uploaded Avatars. (They were stored in the database.)

    I know this is a fairly terrifying step, since all your members have Avatars already. Is this too big a leap? If so, I can keep digging. Ultimately, I think it's because both plugins are trying to claim the WP avatar class, and it's making your poor server distraught. Not distraught enough to fail or throw us a friendly error message, however.

    Let me know what you think.

  • peter_harris
    • Syntax Hero

    Ahh, so disabling the other plugin wasn't enough, it has to be completely deleted? That's TOTALLY FINE if I know it's going to work afterwards. I think I might do a test of this on a dummy site to confirm just before, but if that is the solution, then it solves the problem!

    Will report back...

  • peter_harris
    • Syntax Hero

    Didn't work on a test site.

    I installed WP User Avatar, uploaded an image and then activated Avatars. Tried disabling WP User Avatar and had the same experience as before (well, in this exact instance I didn't see the broken image, it just refreshed the page after cropping.) Next I deleted WP User Avatar completely and tried another test with Avatars.

    For my second test, I went to another install entirely. This one never had any avatar plugin. I installed and uploaded an image. This time I saw the "Avatar updated" message, but there's no avatar displayed anywhere.

    So that leads me to believe that there's something specific to your plugin and Nginx and/or the Easy Engine install process from RTCamp (that Ari suggested) that isn't compatible with this plugin.

    Thoughts?

  • Michelle Shull
    • DEV MAN’s Apprentice

    Oh no, I'm sorry to hear that.

    This has been a real bear for you, I want to assure you that most of the time, running a WP site is much, much better than this. : ) You're getting your trial by fire with avatars.

    Let's call in the big(ger) guns, second level support. My bag of tricks is empty, and I suspect you're right, there may be a conflict between your set up and this plugin. Our second level folks are the best, if there's a solution or a workaround, they can definitely find it.

    Thanks so much for your patience on this!

  • peter_harris
    • Syntax Hero

    Update: tried turning debugging on for a subsite and then tried uploading again but no luck and no errors posting.

    Have enabled Support Access for whoever can jump in. Getting a bit desperate as much of the next stage of my site promotion revolves around users uploading photos and filling out their bio.

  • Hoang Ngo
    • Code Slayer

    Hi @peter_harris,

    I hope you are well today and I'm really sorry about the issue.

    Look like you install your own server.

    The Worpdress Image Class will be required GD2 library or Image Magick. But the Image Magick is recommend as it faster, better quality and also save resource when running.

    Can you please have a little describe about your environment (nginx, php version ?, etc).

    Thanks!!!.

    Best regards,
    Hoang Ngo

  • Hoang Ngo
    • Code Slayer

    Hmm,

    I have try your sftp information, it work for me, but it seem it not listing right directory. Please check in the screenshot.

    Can you please take a check for this, I will need this to have some test.

    I'm really sorry about this inconvenience and many thanks for your patience.

    Best regards,
    Hoang Ngo

  • Hoang Ngo
    • Code Slayer

    Hi @peter_harris,

    I can access it now. Thank you.

    Also, for security, please restrict the other users to it home folder or other folders they allowed. For now, I can access to almost folders there, this is somehow dangerous.

    I will have some test and keep you update shortly.

    Thanks

    Best regards,
    Hoang Ngo

  • Hoang Ngo
    • Code Slayer

    Still not work for me @peter_harris :slight_frown:

    You can add me to a group same as the owner of that folder, and then use this command
    chmod -R G+rwx /path/to/the/folder.

    This will give all the users in same group as owner have ability for read/write and execute.

    Best regards,
    Hoang Ngo

  • peter_harris
    • Syntax Hero

    I've already spent 2-3 hours trying to learn how to assign access to a user to the specific folders where WordPress is installed on my server and I can never find any clear answers from the dozens and dozens of tutorials, forum posts, etc. Never gets me anywhere.

    Been two weeks since I reported that this plugin doesn't work and I'm no closer to solving this problem than when I started.

    BEYOND FRUSTRATED.

  • Hoang Ngo
    • Code Slayer

    I'm sorry for your feeling and I understand the reason. But I will need to have the tools for working and fixing bug :slight_frown:. If you aren't familiar working with ssh, then can you please send the root access to me ?

    Can you please send in:

    - Mark to my attention - ATTN: Hoang Ngo
    - Link back to this thread
    - SSH root account
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    Thanks!!.

    Best regards,
    Hoang Ngo

  • peter_harris
    • Syntax Hero

    Closing this. After five or six hours, I don't have time to continue debugging this. WP User Avatar works for my main site. Won't have avatars for the whole network, but if I have to live without it.... then so be it.

    Suggest you have someone on the dev team try to get it working for nginx/ubuntu configuration installed with EasyEngine. This is what Ari AKA Aristath recommended to me for setting up multi-sites and Avatars doesn't work on ANY of the three systems I've installed using that.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.