Expired users even though Stripe has successfully charged

Hello I now seem to have the opppostive problem from what I reported a while ago.

Some users (example @kabbalahscribe ) have expired due to payment not being detected (and show gateway as not existing in plugin) but Stripe has an active subscription for them.

How do we fix this?

  • Milan
    • WordPress Wizard

    Hello @Dre,

    I hope you are having a good day and thanks for the asking. :slight_smile:

    Some users (example @kabbalahscribe ) have expired due to payment not being detected (and show gateway as not existing in plugin) but Stripe has an active subscription for them.

    I can confirm this issue on your site but I am not able to replicate on my sandbox site. Its hard to predict which thing can cause such behavior. Can you tell me how you've added that member on your site ? Is it were added manually or by following default registration process provided by membership ? I am asking this to you because I can't find transaction entry for that user.

    Looking forward to hearing back from you.

    Cheers,
    Milan Savaliya.

  • Dre
    • The Incredible Code Injector

    Hello @Milan thanks for your reply.

    I can tell you that all paying users have joined via normal means and registered their membership by going through the checkout process provided by the plugin.

    I had noticed that some users appeared to have lost their gateway information some time ago but as it seemed not to affect anything I had left it alone BUT as of the latest plugin update something has changed and the system rightly decided to expire these accounts because (I am assuming) it could not match them up to Stripe.

    All the users exist in Stripe, and have had a subscription created by the system, any way to relink the two sides? Less concerned as to why it happened (since I think it happened ages ago and only now became a problem) and more about how to fix it

  • Dre
    • The Incredible Code Injector

    Hello @Milan did one of you guys at WPMU try to turn on the membership test mode? Unfortunately it causes cache errors since a few versions ago giving 503 to anything on the front end, I had to turn it off.

  • Dre
    • The Incredible Code Injector

    URGENT @Milan @Kasia Swiderska @Michael Bissett

    I have lost more users today as the system clears them out from failing to connect with their respective Stripe account and so decides they haven't paid. This is a Priority 1 emergency for us.

  • Milan
    • WordPress Wizard

    Hello @Dre,

    I hope you are having a good day and sorry for being late here. :slight_smile:

    Its strange and kind of complex issue where my knowledge is not enough to assist you further on this so I've flagged one of our SLS( Second Line Support ) staff to assist you further. I am sure they will get back to you as soon as possible. It may take some more time for them to response you as they everyday deals with lots of critical issues.

    if its okay to you, can you downgrade to older version of membership which you were using before update ? You can get all the versions of membership which are released till now on our products usage page here,
    https://premium.wpmudev.org/project/membership/. Click on changelog link.

    Kind Regards,
    Milan Savaliyla

  • Dre
    • The Incredible Code Injector

    Hello @Milan the thing here is that i think this is actually an issue I had a long time ago with an older version of the plugin, let me explain.

    At some point the plugin lost the gateway to a number of my users BUT a different issue prevented these memberships from expiring so they just ticked along BUT THEN the latest version finally figured out that from WP's point of view their membership should be over (as there is no link to stripe) and terminated it.

    What I think I need here is a way to get all the users with a missing gateway re-linked to their Stripe counterpart, how can we get this done? Will your SLS be able to do something like this? or even manually edit the database to re-add Stripe tokens?

    I am worried about the idea of downgrading even temporarily and causing even more of a mess, can I get your SLS colleagues opinion/reassurance that this will not compound the problem?

    Thank you for your assistance

  • Milan
    • WordPress Wizard

    Hello @Dre,

    I already flagged one of our SLS staff on this, I am sure they will get back to you as soon as possible. Our SLS staff everyday deals with complex issues and bugs so it may take some more time for theme to attend this thread. but they will attend this ass soon as possible.

    Kind Regards,
    Milan Savaliya.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.