Extremely slow loading

Our site is too slow to load.
I can not find out why it is slow.
When the page is in the cache, okay, loads quickly. But when it is not, it takes almost 2 minutes to load.

We use the WooCommerce and Sensei plugins.
We also use Amazon ElasticCache with Redis for the W3 Total Cache plugin.

  • James Morris

    Hello Marcello Kera,

    I hope you are well today.

    Thank you for having Support Access enabled so I could take a look at your site. :slight_smile:

    I ran your site through 2 tools to help determine what's going on. I used both https://tools.pingdom.com/ and https://gtmetrix.com/ Both are indicating that you have a lot of room for optimization of scripts and images. Also, there's some server tweaks that can be applied that would help significantly.

    It's a good idea to use services such as these to help identify problem areas on your site and work through the suggestions they provide, whenever possible.

    First, I see you're currently running PHP 5.6. While this is a stable and supported version of PHP, it is getting quite aged. PHP 7.x is more modern and includes some significant performance enhancements that would help your site load faster. I recommend updating to the 7.x branch of PHP if at all possible.

    Also, I'm seeing your current memory_limit in PHP is 256M. While this is fine for smaller, low traffic sites, a site like yours with many plugins will have some performance degradation using such a low value. I'd recommend changing your PHP configuration to allocate at least 512M and then updating your wp-config.php to make use of this extra ram.

    Next, I see you have W3 Total Cache installed. While this is certainly a good plugin. I think in your situation you may find our Hummingbird plugin to be a better fit for your needs. It's comparable to W3TC and much simpler to configure.

    If you are set on using W3TC, you are going to need to go through the settings of that plugin and make sure you've configured it fully - being careful to disable any options you are not using. I'm seeing some features enabled that are not fully configured which can actually slow performance.

    Some specific areas you're going to want to consider are Browser Caching, Gzip Compression and Headers.

    Also, you may want to revisit WP Admin -> Media Library -> WP Smush and perform a Bulk Smush. I'm seeing 1637 attachments that need smushing! This can certainly degrade performance.

    I hope this clarifies a bit. Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris