Facebook API and Permissions seem to work but Comments and Autoposting don't recognize my Pages

So I've followed the video tutorial for setting up the Ultimate Facebook Plug-in and things seem to be going smoothly for the most part.

My question is, on the video tutorial I see the option to "skip importing comments for these accounts" and all of the facebook pages associated with the account appear.

In my installation of the plug-in, I don't have any pages with checkboxes available.

Next, Under the 'Autopost to Facebook' Tab, When I go to "Map Wordpress types to Facebook locations," and try to Autopost Posts/Pages/Media to ... of this user: (dropdown), the dropdown menu where I should be able to select a user is empty.

I just joined today and I'm eager to get started! Thank you in advance for any advice!!! :slight_smile:

  • Dakota

    Whenever you get a chance, Ashok I could sure use some help!

    Which video tutorial was it you were recommending I watch? I've gone through the playlist on youtube twice now and the plugin doesn't seem to be working properly.

    All of the features look awesome on the demo videos, I really want to implement them correctly! The Like button seems to work, but the share button is not including the correct title or image as specified in my plug-in settings (it shows the date of the post instead of the title and a thumbnail from the wrong video). I followed the instructions correctly to the best of my ability.

    Your response would be very much appreciated,

    Regards,

    Dakota

    • Tyler Postle

      Hey again Dakota!

      Hope you're doing well today :slight_smile: working alongside Ash on this one. Thanks for your patience here.

      Here is the video that Ash intended to post above: https://www.youtube.com/watch?v=q3-XfRjXFIk&feature=youtu.be It was created by an awesome member from the community recently so it's up-to-date and should have every step in there.

      So, follow along to that if you haven't already seen it and ensure everything is where it should be.

      If all is well then would you mind granting support access? You can do this via your dashboard - WPMU DEV > Support > Support Access > Grant Access.

      Then we can double check all your settings and see if we get the same problem on our installations.

      I re-call your screenshot from our live chat and know that I'm also missing that option; however, that shouldn't affect the comments or autopost feature - so let's get those working first :slight_smile:

      Look forward to your reply!

      Cheers,
      Tyler

  • Dakota

    Hey Tyler!

    Thank you for your response! I followed the tutorial and added the extra URLs to the app info section in the facebook developers app. I'm still getting no response from the comments and no connection to my account through the app.

    I have Jetpack installed on this site as well, could that be causing some problems? I just disconnected the facebook from Jetpack, but I'd rather keep it connected as it actually works at the moment. Could you see if there's a conflict there?

    I've granted access, please let me know if you need me to do so again later in the day!

    Thanks in advance!

    Dakota

    • Tyler Postle

      Hey Dakota,

      No problem, happy to help :slight_smile:

      I have a couple possible solutions to try out here:

      For comments:

      It looks like your post comments are turned off - I have enabled the discussion widget so you can toggle them on/off per post. This option will be near the bottom of the edit post screen. Screenshot attached.

      You can change this for all new posts by going to Settings > Reading > Default article settings and make sure "Allow people to post comments on new articles" is checked.

      If you don't want WordPress comments to show then there is an option in the Ultimate Facebook comment settings that you can check :slight_smile:

      For AutoPost:

      I am wondering if you are able to manually send posts over. I turned off auto post (hope you don't mind!) and you should have a box underneath the discussion settings for each post - you check the publish to facebook box and save - see if it publishes then :slight_smile:

      You may have to grant your app further permissions to publish to facebook - you will see link for that in below the checkbox - screenshot attached.

      Hope this helps Dakota! Let us know how it goes and we'll assist further if needed.

      All the best,
      Tyler

      PS. There is a chance that JetPack's social media features could be conflicting; however, it doesn't seem like it so far. We'll see whether the above solutions work or not :slight_smile:

  • Dakota

    Hi Tyler!

    Thank you for your response! I'm now using Ultimate Facebook for the Comments section of my site. I wanted to have the wordpress comments replaced with the facebook comments displayed from this plugin and that's working correctly.

    I was having an issue with the Open Graph part of the plugin--it was showing an empty link to the archives with the date that the post was created. It also had the wrong thumbnail (a thumbnail from one of our other YouTube videos o_0).

    After you got the comments working for me, I saw in the comments section that there was a warning about the url for the post--something that didn't make a lot of sense. I clicked the link and it took me to the facebook developers site where there was an option to debug.

    I clicked on 'enable debug' and it refreshed the page but the error message was still showing. Thankfully, when I went back to the website, the 'share' button was displaying the proper thumbnail and description for the open graph. One of our fans had sent me an email saying it wasn't working, so I was able to send her an email to check it again and now it works!

    Thanks so much for your help! I will post a couple of screenshots when I get home tonight so if anyone else runs into the problem they can see how I solved it.

    Just one minor issue as I would really like to phase out Jetpack, the Ultimate Facebook plugin is putting a light grey box around the Facebook Like Box. I'd really prefer that it not be there. The one from Jetpack doesn't have the border and I prefer the look of it, just don't want the weight of the extra plugin. Can you tell me the proper CSS selector I can use to remove the box?

    I take it from reading the plugin settings that facebook connect is being phased out, is that correct? I was thinking it would be wonderful to try to use Facebook to speed up the process of opting in to our email list. Do you have any thoughts about the best way to do that?

    Regards and thanks again for all of your help!

    Dakota

  • Michael Bissett

    Hey @Dakota,

    ...the Ultimate Facebook plugin is putting a light grey box around the Facebook Like Box. I'd really prefer that it not be there. The one from Jetpack doesn't have the border and I prefer the look of it, just don't want the weight of the extra plugin. Can you tell me the proper CSS selector I can use to remove the box?

    Unfortunately, that isn't something that can be styled by using custom CSS code, since the widget is embedded in an iframe. However, there is a way to modify this, though it does require editing the plugin code a bit.

    If you go to wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_widget_likebox.php, and scroll down to line 122, replace the following code:

    $height . '"

    with this:

    $height . '&show_border=false"

    That'll remove the border for you. :slight_smile:

    As for this:

    I take it from reading the plugin settings that facebook connect is being phased out, is that correct?

    Yes, that's correct. :slight_smile:

    I was thinking it would be wonderful to try to use Facebook to speed up the process of opting in to our email list. Do you have any thoughts about the best way to do that?

    Not sure what newsletter service you're using, but AWeber actually provides this kind of functionality:

    http://www.aweber.com/blog/new-features/facebook-registration-for-your-web-forms.htm

    Would something like that suit your needs? :slight_smile:

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.