Facebook Autoposting too much

So Ultimate Facebook autoposts new posts to my FB page. Great.

But … not so great is how the plugin autopost to Facebook every time I change old posts, whether it’s featuring them on the front page or making an edit.

Is there a way to config the plugin so that only new posts are autoposted, not old posts?

  • Diduwin
    • Design Lord, Child of Thor

    Timothy,

    Since I only installed the Ultimate FB plugin in the last week, most of my site’s 500-plus postings have not been posted to FB via the plugin.

    The plugin has autoposted new posts just fine.

    However, many times I display old posts on my site’s front page and I’ve noticed the plugin is also posting those old posts to FB, sometimes when I move a post to the front page, sometimes when I remove it from the front page. It’s also posting old posts to FB if I happen to change the featured image.

    Also: I can’t locate what’s in the second of your screen shots, with the “delete” and “update” buttons. Where do I find that and what’s its purpose?

    thanks,

    Diduwin

  • Timothy
    • Chief Pigeon

    Hey there.

    The plugin checks the custom field, if you don't see the custom fields then go to the "screen Options" and enable it.

    You can change the wdfb_published_on_fb from 0 (nothing) to 1. If t doesn't exist then make it.

    This is where UFB checks so if it's marked as sent it shouldn't send again I believe.

    Thanks.

  • Vladislav
    • Dead Eye Dev

    Hello,

    As Timothy said, “wdfb_published_on_fb” is the flag used by the plugin to indicate the post has been already published on Facebook – this is automatically set for all auto-published posts. Additionally, the plugin should be checking your post’s previous published state, and decline the auto-publishing if it was previously published. Is it possible that your older posts had a status set to something different?

  • Diduwin
    • Design Lord, Child of Thor

    Ok so, yes, I’ve added “wdfb_published_on_fb” with a value of 1 and the plugin is still posting to facebook “sometimes”

    more disturbingly, today I was re-editing an old post, previewing it as well, and to my shock the post was then autoposted to fb … I hadn’t even updated the post yet, just previewed!

    and yes, older posts in question all have “published” status

    seems as tho the only way I’ve been able to control the autoposter monster is to turn that feature off

  • Diduwin
    • Design Lord, Child of Thor

    Happened again today.

    I edited an almost 2-year old post, previewed it, checked my FB page and saw it had been posted. This is without updating the post or before adding any custom value (after all, I was only previewing, not publishing).

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.