Facebook Connect not creating users

Hi!

I'm running Ultimate Facebook 2.6.2, WordPress 3.5.1 (with multisite) and BuddyPress 1.6.4.

Ultimate Facebook is correctly configured and most of the features are working as intended (importing Facebook comments, etc.). Facebook Connect, however, is having some problems. Here's a screenshot of the configuration: http://i.imgur.com/MqOSOWJ.png

The problem is that when "Login with Facebook" is clicked, it loads for a couple of seconds and then redirects to a 404 at http://SITEURL/members//profile/edit (i.e. the "USER_LOGIN" macro is coming up with a blank). No user is being created in the database.

I have tried disabling Ultimate Facebook and testing other Facebook Connect plugins (principally Nextend Facebook Connect), and they are successfully creating users in the database, but they have other problems with the redirect that make me prefer Ultimate Facebook.

Any ideas? Please let me know if there's anything I need to send you (including dashboard access) that might help you.

Many thanks!

Joe

  • Vaughan
    • Support/SLS MockingJay

    hi @JoeLitobarski

    thanks for posting.

    can you try using the default 2012 theme?

    have you granted extended permissions?

    network dashboard > facebook settings > permissions & tokens.

    you should see a link to click that says create extended permissions if you haven't already.

    you can also refresh the user access token.

    let me know how it goes.

    thanks

  • Debating Europe
    • Flash Drive

    Hi Vaughan,

    Many thanks for your response!

    I switched to 2012, but no joy. I also deactivated all plugins except Ultimate Facebook, but the problem was still there.

    I have granted extended permissions to the plugin.

    Also, if it helps, I noticed in the Javascript console that I'm getting the following on the 404 page after the redirect: "FB.init has already been called - this could indicate a problem"

    Joe

  • Vaughan
    • Support/SLS MockingJay

    Hi @joelitobarski

    I'm going to ping V on this, see if he can give some feedback, I am unable to replicate it.

    though I was having some problems when sandbox mode was enabled on the app in facebook. turning sandbox mode fixed the issue. kept saying API key was invalid, but I'm not sure that's related to this issue.

    regards.

  • Vladislav
    • Dead Eye Dev

    Hi,

    Thank you very much for the settings screenshot. Can you please tick your "Allow single-click registration" checkbox, so it's checked and save your settings? Without this setting enabled, the login button will attempt to log your user in but won't create a new user if he or she doesn't already have an account on your site.

  • Debating Europe
    • Flash Drive

    Hi Vladislav!

    Apologies, I should have checked out the settings in greater detail! The plugin is now correctly creating users in the database, so that problem is resolved.

    However, the USER_LOGIN macro is still serving a blank URL instead of the username of the current user. Any ideas what might be causing it?

    Let me know if there's anything I can send you!

    Joe

  • Vladislav
    • Dead Eye Dev

    Hello,

    I'm sorry for the delay - just to make sure, is it just the USER_LOGIN macro that's refusing to expand to a meaningful value? Have you perhaps tried other ones? Also, is it not expanding at all (i.e. you can literally see USER_LOGIN in the URL), or does it get expanded to a wrong or empty value?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.