Facebook LIKE doesn't work because domain is banned by Facebook

Dear all,

I recently post a support ticket regarding the Facebook Like Reset to ZERO -
https://premium.wpmudev.org/forums/topic/facebook-like-reset-to-zero#post-229012

Initially I thought it is the plugin issue, but WPMUDEV mentioned that my domain is somehow "BANNED" by Facebook.

Do you know how do I verify this and report to Facebook for such issues?

  • James Dunn

    Mari Smith posted an article back in 2010 with about 120 forms for contacting Facebook located at http://www.marismith.com/how-contact-facebook-directory-of-forms/ - you can look through those to see if one of them applies to your situation.

    This happened to a friend of mine that runs an online radio station and he - nor any of his fans - could post his link. It lasted about a week or so. For him it was a temporary thing and now he's more careful about posting. Before he got banned, he was posting links to his website almost every hour I cautioned him that he should only post two or three times a day directly back to his website. If he wanted to post more, he could post links to other websites of similar interest (artist he was playing, news stories about the music he was playing, etc). He changed up his approach and he's not able to fully post.

    Hope either the forms - or time - will help you get "un-banned". That's no fun when you are building a business around FB and they pull the rug out from under you. We've always cautioned our clients that they need to build their business outside of Facebook because if FB shuts them down, all they have left is what they build off FB. I realize this is just a sandbox site for you, so that doesn't apply, but I wanted to post that comment here for someone else that may read this in the future.

    JDD

  • easywizard

    I just got a feedback from WPEngine guy who's working on this matters too, and here's the feedback:

    This is handled through an iframe, so this has nothing to do with the server, since the request is made from the client.

    This is the iframe from the source:

    <iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Ftestbed.enclavelabs.com%2Fpay-with-a-like%2F&send=false&layout=box_count&width=100&show_faces=false&action=like&colorscheme=light&font&height=60" scrolling="no" frameborder="0" style="border:none; width:58px; height:62px;" allowtransparency="true"></iframe>

    And this is the response I get from the request:

    for (;:wink:;{"__ar":1,"payload":null,"jsmods":{"require":[["Plugin","disconnect",[],["http:\/\/testbed.enclavelabs.com\/pay-with-a-like\/"]]]}}

    So it looks like Facebook is rejecting the the like for some reason, but it's not based on the server since this request is made from the client machine and not the server.

  • easywizard

    Received a feedback from the WP Engine support that seems to be very helpful in trying to understand the problem.

    So an iframe is used to load the like button. This iframe's source is directly to Facebook and when clicking the Like button, the request sent originates from the user's computer. The server hosting your site is never involved with this.

    So for some reason, Facebook is rejecting the request.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.