Facebook Login Issue --- Tried fixes from other posts with no luck

I am trying to use this plug-in and the facebook login (and google login) both don't work - I've tried it in Chrome, Firefox, and Internet Explorer) - here are the fixes I've tried as well:

- activated twenty eleven theme - still not working
- deactivated ALL other plug-ins but Comments Plus - still same thing
- I've checked and double checked the Facebook App information - appropriate numbers were copied correctly and the domain/website settings are correct.
- I have Sociable WP3 plug-in installed - so I've checked the box next to: Pages on my website already use javascript from Facebook --- still not working.

I used the Chrome Inspect feature and switched to console (after reading the other posts with the same issues) - this is what is displayed:

Uncaught ReferenceError: jQuery is not defined faq.js:1
Uncaught ReferenceError: jQuery is not defined jquery.tipsy.js:104
Uncaught TypeError: Object #<Object>has no method 'getLoginStatus' facebook.js:12

The Facebook "share" feature of the Sociable WP3 plug-in is working - just not the facebook portion of the comments plus plug-in.

http://www.getproductivebooks.com is the main site - comments are turned off on the home page, but the blog posts allow comments:
http://getproductivebooks.com/uncategorized/test2/

Any assistance or thoughts are greatly appreciated :slight_smile:

Thank you!

Liz Martinez

  • DavidM
    • DEV MAN’s Mascot

    Hi Liz and first off, welcome to WPMU DEV!

    It sounds like you've gone through all the proper troubleshooting methods but just to check, you did disable the Sociable WP3 plugin while testing as well, correct?

    Given all the troubleshooting thus far I can't really see how it could not work, especially if you've tried it with Twenty Eleven and all other plugins deactivated. Have you tried that specifically though?

    If you wouldn't mind sending through an admin login, I'll gladly take a look to see what I can find there. If so, you can send that through the contact form, marked attention to David, with a link to this thread for reference.
    https://premium.wpmudev.org/contact/

    Thanks,
    David

  • DavidM
    • DEV MAN’s Mascot

    Hi lizmsolutions,

    Thanks for sending that info through, I can see you're actually on version 1.1.3 of Comments Plus. Could you please update to the latest version 1.3.1?

    There were a few things updated with regard to Facebook functionality recently so that may just sort it.

    Thanks,
    David

  • lizmsolutions
    • New Recruit

    Ok, I've updated the plugin - still wasn't working as long as I had the "sociable WP3" plug-in activated.

    So, now that I've deleted the "Social WP3" plug-in the google login works, but the facebook is not working - could my app be set-up incorrectly? Could there still be some other issue?

    I appreciate your time and assistance with this.

    Liz Martinez

  • lizmsolutions
    • New Recruit

    ok, so I tried one more thing in troubleshooting - and I've now narrowed the issue down to something in the theme - if I put the default theme in place, then the plug-in works.

    I know this is beyond the support on the forum, but if you have any thoughts on where I should look in the theme files to figure out the conflict, I would greatly appreciate it.

    Liz Martinez

  • lizmsolutions
    • New Recruit

    Figured it out - there was extra javascript functions in the theme for additional customizations of headers and backgrounds --- I wasn't using those features at all, so I removed them from the theme and everything is working fine now.

    Thank you again for your time and assistance.

    Liz Martinez

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.