Facebook OpenGraph Settings - Error

I'm trying to connect my Events to FB.
I've inherited the project, which is currently using wp-events-manager as their Event Management system (because of the Stripe.com payment options, I believe).

Not only are the events NOT fully posting to FB, but I also keep getting the following errors in the "OG Settings Meta box" when creating an "Event".

Warning: Invalid argument supplied for foreach() in http://guildlocal.com/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_metabox.php on line 187:

<?php
foreach ($images as $idx => $image) {
$name = esc_attr($image);
$markup .= '<div class="wdfb_repeatable wdfb_repeatable_image">' .
"<label>" . __('Image URL', 'wdfb') . ":</label> <input type='text' class='widefat' name='wdfb_og_images[{$idx}]' value='{$image}' />" .
'' . __('Remove', 'wdfb') . '' .
'</div>';
}
?>

Warning: Invalid argument supplied for foreach() in http:///guildlocal.com/wp-content/plugins/wpmu-dev-facebook/lib/class_wdfb_metabox.php on line 206:

<?php
foreach ($names as $idx => $name) {
$name = esc_attr($name);
$value = esc_attr(@$values[$idx]);
$markup .= '<div class="wdfb_repeatable wdfb_repeatable_custom">' .
"<label>" . __('Property name', 'wdfb') . ":</label> <input type='text' class='widefat' name='wdfb_og_custom_name[{$idx}]' value='{$name}' />
" .
"<label>" . __('Property value', 'wdfb') . ":</label> <input type='text' class='widefat' name='wdfb_og_custom_value[{$idx}]' value='{$value}' />" .
'' . __('Remove', 'wdfb') . '' .
'</div>';
}
?>

Does this plugin work perfectly with the Events+ plugin?