Facebook Pages

The plugin works well for me in every area but I do have one minor problem & wondered if a) I can correct it or b) if it is a bug that needs correcting.
My preferable settings are to post to my facebook page as opposed to my profile. This can be done in the settings without a problem. However, whereas if I post to my page from within facebook because I am obviously admin, it publishes as the page and does not show me as the user posting which is how Facebook is designed. When the plugin posts to the page it posts as my own profile & doesn't pick up the fact I am admin of the page and post as admin.

Any help would be appreciated as to whether this is an error or bug or resolveable.

Thanks for an awesome plugin,

Mark

  • DavidM
    • DEV MAN’s Mascot

    Hi Mark,

    I'm not totally sure on that one but could you please try it with the very latest version 1.0.2?

    It would help to know if it's working in that way with the latest version, at which point we can see about getting that implemented.

    Thanks,
    David

  • Atkotech
    • Recruit

    Spoke too soon David, the problem isn't resolved. I have an interesting but strange problem though in that I use the Wibya toolbar. if i check my facebook page through the toolbar it shows as posted by the page. If i physically go on to the facebook page it shows as posted by my personal profile.

  • aodmarketing
    • WPMU DEV Initiate

    I have the opposite problem ... I just installed the new version, and it only seems to post to facebook if I am using facebook as myself. If I switch to using facebook as the page, the article does not post when i publish in wordpress. I would rather post it as the page, not my profile. is there a way to do that? and how can i make sure it always publishes whether or not i am using facebook as myself?

  • ClvrTv
    • Site Builder, Child of Zeus

    The "post AS page" feature is not working for me in 1.0.8. It is still posting as my user profile instead of as the page itself. Am I doing something wrong? See attached screenshots.

    Clvr Tv is the name of the Page that it should be posted as. Other services correctly post as the page but the ultimate FB plugin through the ClvrTv app configured in the settings will only post as the user (ClvrTv Andrew) to the Clvr Tv page.

    I notice that when I check/uncheck the "post AS page" setting another browser window with the FB "busy" icon flashes and then disappears. If I refresh the FB plugin settings page often the "post As page" setting gets lost - if it was checked it is no longer checked. But even when it does stay checked, it doesn't actually see to work.

    Thanks.

  • DavidM
    • DEV MAN’s Mascot

    Hiya Andrew,

    As far as you can recall, did you ever see the window where you can "Allow" the request (should have appeared at least the first time you ticked the option to post as Page)? I imagine not actually pressing the Allow button might be the culprit here if you've never seen the option presented.

    If you could verify that, it would help determine a fix for the matter.

    Thanks,
    David

  • ClvrTv
    • Site Builder, Child of Zeus

    Interesting - I suspect that is definitely the issue. Naturally I went through granting extended permissions and that worked ok because I could pick the different pages I'm an admin for.

    However, every time I try to toggle the "post as page" setting the only thing that happens is a blank FB dialog pops up and disappears again in a second or less. I'm assuming this is the Allow button page that you're referring too, but I never get a chance to click it.

    It's odd that if I'm not logged into FB ahead of time, when I click the "post as page" checkbox I get a small new window for logging into FB. But once I'm logged in it disappears too and then the same behavior with what must be the Allow dialog. If I'm already logged in it just flashes and disappears. I was able to grab a screenshot the split second before it disappears. This happens in Chrome and FF.

    Thanks!

  • DavidM
    • DEV MAN’s Mascot

    Thanks for confirming that Andrew. I'm actually seeing something eerily similar on a test site where the "Allow" request doesn't show any longer yet I do see a quick display of the popover as you've posted. In my case, the first time the popup displayed, I was able to and did press to Allow the request.

    I imagine in your case it wasn't allowed for whatever reason and now, no longer can be.

    I'll mention this to the developer.

  • ClvrTv
    • Site Builder, Child of Zeus

    Almost exactly correct. The only difference (because I'm fairly detail oriented :slight_smile: is that in 1.0.8 the "Allow" button window would flash and disappear every time "post as page" was clicked to checked OR unchecked, whereas in 1.0.9 the window flashes and disappears ONLY when the "post as page" is clicked to checked.

    But it is still disappearing instantly and not possible to "Allow." Thanks!

  • Vladislav
    • Dead Eye Dev

    Hi,

    Since posting as page was introduced after the plugin got released and it required a new permission from Facebook to work smoothly, we need to check to see if the user actually allowed it for us, rather then asking all our users to just re-grant their permissions. The window is popped up to ask you to grant the permissions, but at that time it figures out that you already granted them and that there is no reason for it to be there, so it auto-closes.

    There was a bug with post as page process that was fixed in 1.0.9. Is the original bug (posting as user rather then page) still happening for you? If so, can you please try to disable auto-posting and try to post to Facebook from the post editor page (using the Facebook metabox below the post editor itself) and see if that made any difference?

  • ClvrTv
    • Site Builder, Child of Zeus

    That was very helpful to know that the secondary Allow window disappearing is not a problem. There was an issue keeping the "post as page" state saved in previous versions, but I'm happy to report that in 1.0.9 after a quick test it does seem like the "post as page" feature is working as it should now. I'll keep monitoring. Thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.