Facebook "post as page" does not show page name

Hi,

when posts are auto posted to Facebook via the Ultimate Facebook plugin, they are posted by my Main blog name, not the page name.

I checked my settings and the checkbox "If posting to a page, post AS page" is checked and the proper user/page is selected under "Autopost messages to 'Facebook wall' of this user 'oogopalblasserwaard.nl'".

The message is posted to the correct wall but it shows as posted by 'OogopNederland Blog' which refers to the main corporate site, instead of the individual blog.

When I uncheck the "If posting to a page, post AS page" checkbox, messages are posted under my personal account, so it does seem to have an effect.

I also check the name of the facebook page in facebook itself, and that is correct as well, showing the actual page name.

I am using a single facebook API connection for all blogs.

Any idea why this is happening?

  • Tyler Postle
    • CGO

    Hey Bart,

    Hope you're doing well today!

    When it says posted to your blog as page it means as your Facebook page name, so instead of your personal account posting it to facebook, it will show as your page posting it :slight_smile:

    Is the name of your Facebook page "OogopNederland Blog"?

    Do you mind linking to your Facebook page that you have it autoposting too, then we can get a better idea of what is going on here :slight_smile:

    Look forward to hearing back Bart!

    All the best,
    Tyler

  • Bart
    • Design Lord, Child of Thor

    Hey Tyler,

    thanks for the quick reply. To answer your question: No, the name of the facebook page is not 'OogopNederland Blog'; it is 'Oogopalblasserwaard.nl'

    This is just one example, but I have 18 more facebook pages, all with different names which all show posted by 'OogopNederland Blog' instead of their actual facebook page name.

    All sites have the 'If posting to a page, post AS page'-checkbox checked.

    The link to one of these facebook pages:
    https://www.facebook.com/Oogopalblasserwaard.nl

    Looking forward to your reply!

  • Tyler Postle
    • CGO

    Hey Bart,

    thanks for your reply!

    I just visited your Facebook page and I don't see any that are posted as "OogopNederland Blog", have you removed them?

    Would you mind granting support access to your site? Then we can take a look at your settings :slight_smile:

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Look forward to hearing back!

    All the best,
    Tyler

  • Bart
    • Design Lord, Child of Thor

    Hi Tyler,

    I've granted you access to our environment and have attached a screenshot of what I'm seeing.

    The first line says "Oogopalblasserwaard.nl shared a link" (correct), and then on the second line it says "Posted by OogopNederland Blog".

    Hope you can clarify this! :slight_smile:

    Happy holidays,
    Rinck

  • Tyler Postle
    • CGO

    Hey Bart,

    Thanks for all your patience here!

    I was looking at the wrong place before, thanks for the screenshot and clarification.

    That text there comes from the name of your FB app. So all you need to do is change your FB app name :slight_smile:

    You can change that via https://developers.facebook.com:

    Facebook app > Settings > Display Name.

    Hope this helps Bart!

    Let us know if you have any further questions.

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.