Facing problem regarding updating plugins

Before today everything was going excellent, I just tried to update one of my installed plugin and it asked me to make provide the ftp credentials. Then I tried to install a plugin and theme in both cases found the same problem. I followed the instruction to add lines in wp-config file the ftp credentials but still unable and found the error "unable to create the directory". Kindly guide me how to resolve this issue.

  • Adam Czajczyk

    Hello Rizwan,

    I hope you're well today!

    "Unable to create the directory" along with prompt for FTP credentials is most likely caused by incorrect file (or in this case directory) permissions on the server. You may wonder what has happened since you've been able to install plugins from WP dashboard previously: I guess either a plugin (often it's one of the "security" plugins like ITheme Security) changed those permission or the sever admin did this (they do this sometimes, don't ask me).

    To understand file permissions in WordPress please take a look at this article from WordPress Codex: http://codex.wordpress.org/Changing_File_Permissions

    To fix the issue access your WordPress installation via FTP, go to /wp-content/ folder and change the permissions to 644 (verbally: Read + Write for Owner, Read for Group and Public) for both /plugins/ and /themes/ directories.

    If it doesn't help change those permissions to 755 (Read + Write + Execute for Owner, Read + Execute for Group and Public).

    With these settings you should be able to install plugins and themes from your dashboard again or at least with FTP credentials provided in wp-config.php file.

    Please let me know if it helps and if you have any further questions, I'll be glad to assist!

    Cheers,
    Adam