facivon .ico not accepted

Hi dear,
I am trying to add the favicon to a subsite but it says that the image .ico is not allowed.
It is due to marketpress or wordpress?
Is there a way to add a favicon image as .ico extension?
Thanks,
Paddy

  • James Morris
    • WordPress Enthusiast

    Hello Paddy,

    If you are using a unique theme for each of your subsites, all you have to do is upload your favicon.ico image into the root of the appropriate theme's folder. Be sure to backup the existing favicon.ico file if it exists.

    So, for example, if the subsite you are wanting to change the favicon.ico file is using the Twenty Sixteen theme, all you would have to do is the following:

    * Login via FTP
    * Navigate to /wp-content/themes/twentysixteen
    * Upload your desired favicon.ico file (since one does not exist in that theme)
    * If you are using a theme that does have an existing favicon.ico, simply rename the old file to something like old-favicon.ico before uploading your new favicon.ico file.

    If you are using the same themes for multiple sites, it gets a bit more complicated.

    Doing a quick search, I found an old thread here (2011) where this problem was addressed. You can read the full thread here -> Possible to add unique Favicons to Multisite blogs?

    There's some custom code in that thread you could try, if you like.

    Whenever I've tried to upload a favicon.ico file through the WordPress admin (Admin -> Appearance -> Customize -> Site Identity) it generates an error on the cropping. However, whenever I use a .png or .jpg file, it works fine. If possible, I would recommend trying one of those file formats and see if you can assign a custom favicon that way. If not, the above code may be useful in your situation.

    Please let me know if you have any further questions. I'll be happy to help! :slight_smile:

    Best regards,

    James Morris

  • Paddy
    • The Bug Hunter

    Hi James, Hi Tyler,
    Thanks for your reply.

    Tyler,
    I tried to add the ico format where you suggested, instead it was missing.
    However, the problem I have is during the cropping as described by James.

    For now I will leave it as it is. All the other file formats are working.
    I don't want to add code just to solve this problem.
    I will mark this ticket as resolved for now.
    Thanks,
    paddy

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.