Failed Custom Header upload

I can’t seem to find an answer on the forums to the following situation:

I cropped my image after clicking on upload to header (currently BP Twenty-Ten theme). The first attempt, the image did not display as desired. It did, however, appear in the header. I clicked on the remove button and on the admin Custom Header page under uploaded images the field was filled with black. I tried again to upload an image, cropped as directed and another bar filled with black. I clicked remove again and the default on my site was restored, but I now have four uploaded image fields filled with black.

Please direct me. Thanks!

  • PC
    • WPMU DEV Initiate

    Hello Shirley,

    Thanks for your question and apologies for the delay in answering !

    I now have four uploaded image fields filled with black.

    Would it be fine If I could go in the admin of your wp site and have a quick look to understand the problem in a better way ?

    If the answer is Yes, please provide me the login credentials with a login link on goobindia (at) gmail (dot) com. This way I would be able to get hold of the problem in a better way !

    If the answer is No, please provide me the screenshots of the issue so that I can try to replicate it and get back to you.

    Cheers

    PC

  • PC
    • WPMU DEV Initiate

    Hello Shirley,

    Greetings,

    I uploaded a test image on your header, and after cropping it successfully, I got it to work.

    After that, to replicate the issue, I removed it and then saw that it appears just fine in the header images section and there is no black screen

    Now, I doubt that the image transparency has got something to do with the black images being appeared in the header images section. I would like to know, how did you create those images ? I mean using which software. Saving them in improper format can cause issues like this.

    I personally prefer saving the images in .png format as they support transparency and are also supported by all the browsers with no issues at all.

    I am attaching a screenshot

    Please advise

    PS : The welcome page in dashboard is shown for a new wp install, which once dismissed does not appear. so, no worries :slight_smile: we are good there !

    Cheers

    PC

  • PC
    • WPMU DEV Initiate

    Hello Shirley,

    As we discussed, the issue was with the image and transparency.

    Whenever we choose any image for our header, we just have to make sure, that the image size if good enough to be resized/cropped. The images we were using were quite small and that is why it created a mess :slight_smile:

    You can have them removed using the Media > Library tab and then as I advise, upload a new image which suffice the resolution and purpose.

    Cheers

    PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.