Failure if activated without mulitisite

If this plugin is activated on a non multisite, the whole site goes down with the message 'The Update Services plugin is only compatible with WordPress Multisite.' on a blank screen. Both frontend and backend is broken! Only way to fix is to delete the plugin directly on server using ftp or other file manager.