Failure to delete service providers

It says that all I have to do is remove the services offered by a particular provider, and that will remove the provider from the list. This isn't working.

I have more service providers in the list than I do actual people now, because when attempting to remove service providers, the system ignores me, and sometimes even adds another to the list for what appears to be no reason at all.

Basically it is preventing me from removing service providers. When I try and remove them all, it leaves me with 4. When I set the remaining 4 to the 4 individual people I want and hit save, I'm left with 8.

  • Hakan
    • The Incredible Smush

    Hi,

    For clarification, let me show on an example what you should see and do in case you want to delete a service provider.

    1) In the attached before-save file you will see that I have 4 providers and I want to delete the "hakan8" one.

    2) I simply clear services of this provider as can be seen in to-save file and click Save Service Providers button.

    3) The result can be seen in after-save file.

    I don't think this is complicated, is it so? A+ simply deletes providers without services. This also serves as clearing out of date information, for example you may have also deleted some services before and you have left with some providers without services assigned or available.

    If these do not happen, then you may have a javascript issue on admin side.

    As of 1.0.3 A+ now comes with a javascript error track function. Most of the errors can be caught and the first one is displayed in an error box.

    Please let us know if you see any javascript errors.

    Cheers,
    Hakan

  • Arun Basil Lal
    • New Recruit

    Hey Hakan,

    I just tried it out and it worked for me. Its not complicated, no, but its not intuitive IMO. A "Remove this provider" button would be more handy.

    Thanks for the detailed explanation :slight_smile:

    Hey Charlie, can you upgrade to the latest version and give this a try? I hope it works for you.

  • Charlie Pryor
    • The Incredible Code Injector

    You have to admit though... when it comes right down to it, reverse is an invaluable gear to have, especially if your bumper is up against a wall.

    I have tried everything to get this to reverse itself, and aside from installing it on a completely new Wordpress installation with a fresh database, it hasn't worked. No matter if the user has a service attached to them or not, they remain, and they show up as a blank space on the front end.

  • Charlie Pryor
    • The Incredible Code Injector

    I've also attempted to remove all services as well. They were able to be cleared successfully by removing all text content in the box for each service.

    When this happened though, "admin" user remains active in the Service Provider field, even though there are no services attached to them. These are the four positions that I cannot delete, and if I attach any services to them, or change their names in any way, new service providers are added to the list, instead of taking their place.

    I've attached a screenshot of what I see as something unavoidable without totally restarting my Wordpress installation from scratch, or removing all notions of the plugin within the database (which I haven't tried yet).

  • Hakan
    • The Incredible Smush

    Hi Charlie,

    You didn't mention that you completely deleted those service providers being users from your website.

    This was a case I never thought. Thank you for testing and pointing out such a case.

    As of V1.0.4 if you delete a user who is also a service provider, A+ now fixes its database tables. His working schedules are cleared and his existing appointments are changed as nobody assigned.
    .
    You won't see the users having ID's 2,3,4,5 now.

    Cheers,
    Hakan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.