Failure upgrading subscriptions

I had this problem with Membership Lite, I just upgraded to 2.0 and it is still there.

I get a note from Paypal that I have a new subscription, I have to manually change the person's status on WP (couldn't figure out why, but that's an irritation, not a bug). It worked fine before, but lately I am unable to change someone's subscription level. I can update their Membership level, but I can't designate which is Monthly and which is Yearly. That spot is blank, and when I go to change it, I go through the proper motions, but nothing ever changes.

(BTW- I did deactivate all other plugins and the problem is still there)

  • mightymur
    • New Recruit

    Thanks David. See screen shot.

    I have to manually activate each account and set their subscription level. which, as you can see, I had no problem doing for some time. Then see user Azhure - I try to go to give them a subscription level, it takes me to the page where I can set the level, and I do so, hit OK, and then go back to this exact page.

    Note that I *can* set the Membership level (which is letting them see premium content), but I can't determine whether they are yearly or monthly subscribers.

    I had no problem with this early on, and I have no idea what changed to make it not work. As I said, I've deactivated all other plugins to test, and still have the problem. Let me know if you need more clarification.

  • DavidM
    • DEV MAN’s Mascot

    Hi mightymur, thank you for the clarification. It definitely helps to get as much information as possible on this as I haven't been able to replicate this particular issue.

    Could you try creating a user from the back-end and seeing if you can add a subscription to that user via the Members list? I'd just like to see if the subscriptions can be added to new users.

  • DavidM
    • DEV MAN’s Mascot

    Hi mightymur,

    Thanks for the additional information, I just wanted to make sure I understood the matter properly. I haven't been able to replicate this, but I'm going to run this by the developers to see what might be causing this. Thank you for your patience!

  • Barry
    • DEV MAN’s Mascot

    @mightymur - can you walk us through how to replicate the problem?

    I have to manually activate each account and set their subscription level.

    Does that mean a user can sign up on the front end, click on the payment button, fill in and pay the subscription but they are set on that subscription automatically?

    What do the IPN history logs in your PayPal account say? Are you seeing any errors? It's accessible via the History -> IPN History page.

  • mightymur
    • New Recruit

    The user is able to sign up, the payment goes through just fine. I get the email from paypal that someone has set up a subscription, then I go into "Edit Members" and the person is listed as deactivated, with no subscription. I look up the information in my email and then manually activate them, which is fine. Then I would manually set their subscription status from blank to "yearly" (or "monthly"), and the Level status would automatically change.

    I don't know what changed, but now all of the above happens until it's time to change the subscription level, then I go to the page to set it, choose it in the drop down, click the button, and then the page is exactly the same as it was before, with a blank subscription level. It DOES show on my membership main page/dashboard that i've set someone's subscription level, but it's not reflected in the Edit Members page.

    I am still able to set the level.

    Also, IPN was turned off on Paypal. I'm not sure what URL it's supposed to point to- is that my main blog page or something else?

  • Barry
    • DEV MAN’s Mascot

    Also, IPN was turned off on Paypal. I'm not sure what URL it's supposed to point to- is that my main blog page or something else?

    Ignore that - the plugin switches on IPN for it's own calls.

    What does the PayPal IPN History say? Does it show any errors? It's accessible via the History -> IPN History page in your PayPal account.

  • Barry
    • DEV MAN’s Mascot

    I don't know what changed, but now all of the above happens until it's time to change the subscription level, then I go to the page to set it, choose it in the drop down, click the button, and then the page is exactly the same as it was before, with a blank subscription level. It DOES show on my membership main page/dashboard that i've set someone's subscription level, but it's not reflected in the Edit Members page.

    Not sure what you mean here? Is this something in addition to the initial subscription not being set? When did this start happening?

  • Mason
    • DEV MAN’s Sidekick

    Just a note that as it's been awhile since we've heard from ya I'm gonna mark this one as resolved.

    If you'd like to continue receiving further support though, just re-open this thread and let us know how things are going for ya.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.