FAO JUDE - Help With Must-Use Plugin For Shortcode

Hi Jude and the team,

Recently on a live chat Jude gave me a lot of help to create a must use plugin that would swap out a shortcode that was in 300 of our posts. He gave me instructions to create a must use plugin but I need a little help as after following the instructions it seems I haven't done something right.

This was the code he gave me:

add_filter( 'the_content', 'swap_out_shortcodes', 20 );

function swap_out_shortcodes( $content ) {

$content = str_replace("[s2If !is_user_logged_in()]","[s2If !current_user_can(access_s2member_level1)]", $content );
$content = str_replace("[s2If is_user_logged_in()]","[s2If current_user_can(access_s2member_level1)]", $content );

return $content;
}

I created a php file in notepad for windows with the following code (never done this before so not sure if this is right even)

add_filter( 'the_content', 'swap_out_shortcodes', 20 );

function swap_out_shortcodes( $content ) {

$content = str_replace("[s2If !is_user_logged_in()]","[s2If !current_user_can(access_s2member_level1)]", $content );
$content = str_replace("[s2If is_user_logged_in()]","[s2If current_user_can(access_s2member_level1)]", $content );

return $content;
}

Then I followed these instructions to upload it to the server: http://gregrickaby.com/create-mu-plugin-for-wordpress/

But it doesn't seem to have had an effect.

Can anyone see where I may be going wrong please?

Many thanks for your help

Adam