Farms Theme Pack Installation

Sorry, but I ran into another problem. When trying to install the Farms Theme Pack through the Network Admin Theme UI, I get the following error:
The package could not be installed. The theme is missing the style.css stylesheet.

I have run into this error in the past when trying to install WP version incompatible themes that were supposed to be compatible with the latest WP version. Has this package been updated to work with 3.4.2 Multisites?

Thank you for your assistance.

Kind regards,

Barbara