Fatal error after instaled MarketPress eCommerce

Hello

I am Viera, Mr.Baranek's colleague.

When I instaled plugin MarketPress eCommerce, fatal error was appeared:
Fatal error: 'continue' not in the 'loop' or 'switch' context in /home/px014000/_sub/zdrave-sladkosti/eshop/wp-content/plugins/marketpress/includes/common/payment-gateways/payfast.php on line 180

Can you help me, please?

Thank you

Viera Samsely

  • Adam Czajczyk

    Hello Viera,

    I hope you're well today and thank you for your question!

    That's a rare error related to the PHP version running on your server. The PayFast gateway is not supported anyway with current MarketPress version and at the moment the file is there for legacy purposes. In case it's a new install and you're not using PayFast payment gateway, please try following way:

    - access your site via FTP
    - go to this folder:

    "/wp-content/plugins/marketpress/includes/common/payment-gateways/"

    - rename "payfast.php" file to e.g. "payfast.old"

    This should remove an error and let you use plugin with no further issues. However, in case you'd get some additional warnings in addition to it or the plugin would stop working, please let me know here.

    Also, our developers are aware of this error and it should be permanently fixed soon so please make sure that you're keeping the plugin up to date.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.