Fatal Error after plugin activation.

Keep getting this message everytime I activate marketpress.

Fatal error: Out of memory (allocated 54001664) (tried to allocate 30720 bytes) in /public_html/wp-admin/includes/update.php on line 49

I have 512M of server RAM.

With 1.5G Burstable

Using wordpress 3.4.2

I only have all the newest versions of buddypress, cubepoints, cubepoints-buddypress, cubepoints login widget, adminbar customizer, adminbar minimizer and the custom community theme activated.

Please help I can't resovle this issue.

  • aecnu

    Greetings bcentertainment,

    Welcome to WPMU Dev!

    Thank you for bringing this significant issue to our attention, it is certainly appreciated and concerning.

    The issue here appears to be that you are indeed out of memory, but some brief testing can give us a bigger picture of what is going on there.

    Attached below is a file that you would want to download and extract to your computer, and then FTP it up to your hosting account to the root of your web site.

    We then want to access the file via your web browser using something like:
    http://yourdomain.com/phpinfo.php

    On this file we want to look at the spot where it indicates memory_limit

    Once we know that number I will go into detail about what we got going on there to include the numbers above and what the best course of action/options are to get you going full steam ahead with your sites development.

    Please advise.

    Cheers, Joe

  • aecnu

    Greetings bcentertainment,

    Thank you for sharing that with us, it is greatly appreciated.

    From looking at the php.ini file I would say that even though your memory_limit is indeed set to 1024MB, you have already told that your limit is 512MB.

    I would suspect that your host is limiting the allowed php memory elsewhere then the settings in your php.ini indicate.

    Lets dig a little further before coming to any conclusions.

    Try WP-Memory-Usage plugin and lets see what WordPress itself says that you have.

    Remember in your 512 MB your server must be running everything including your control panels etc. The same within the php memory_limit.

    In addition, though you are told that you have a very powerful VPS, do you really get the power of the 8 cores - I truly think not. It is very rare that a company does this because most are using Vituozzo for VPS's and not custom configurations like we do with our VPS servers. Ours sends all available server power and memory to each site on an as needed basis, so truly one gets 16GB of RAM and all 8 cores when no one else is using it at that moment, of course minus what the CentOS operating system is using at the moment - not some limits imposed but yet another layer of software which as mentioned most commonly Virtuozzo.

    Also by looking at your PHP ini the PHP version is outdated, here is a current server installation:
    http://wpmu-hosting.org/phpinfo.php

    We can already see that they have divided up the memory, what about the processor?

    Please do not be blinded by the sales pitch BS.

    Please advise as to what WordPress says the memory limits are using the plugin mentioned above.

    Cheers, Joe

  • bcentertainment

    Ok I reduced the memory back to 512M and I installed the memory-usage plugin.
    I tried updating php and got this...

    @simplyklick [~]# sudo yum upgrade php
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: http://ftp.linux.ncsu.edu
    * extras: mirror.net.cen.ct.gov
    * rpmforge: apt.sw.be
    * updates: centosa5.centos.org
    base | 1.1 kB 00:00
    extras | 2.1 kB 00:00
    rpmforge | 1.9 kB 00:00
    updates | 1.9 kB 00:00
    updates/primary_db | 825 kB 00:00
    Excluding Packages in global exclude list
    Finished
    Setting up Upgrade Process
    No Match for argument: php
    No package php available.
    No Packages marked for Update

    Now just activating buddypress i get this:

    Fatal error: Out of memory (allocated 44302336) (tried to allocate 6238 bytes) in /home/simplykl/public_html/wp-includes/functions.php on line 3315

    This is so aggravating.

    I can't take it anymore.

  • aecnu

    Greetings bcentertainment,

    Thank you for your additional input, it is appreciated.

    I think giving up is a little drastic and personally by looking at the numbers, it is my opinion there is something wrong with the host.

    What you say you have or supposed to have and what you are getting are two drastically different things.

    The first set of numbers shows you capping out at approximately 54MB's and the second time at 44MB's, something is seriously wrong with that and very possibly a very overloaded or extended server - consider a new host.

    Check out this post:
    https://premium.wpmudev.org/forums/topic/best-host-for-multisite#post-267699

    If interested write to me aecnu (at) incsub.com and I will explain an absolute no risk offer with free migration and be sure to include a copy of this tickets URL:
    https://premium.wpmudev.org/forums/topic/fatal-error-after-plugin-activation

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.