Fatal error: Allowed memory size of 71303168 bytes exhausted

What is the root cause of the error bellow and how do I solve it permanently?

I've been increasing memory. It goes away for a while and then it comes back again.

Thanks

Fatal error: Allowed memory size of 71303168 bytes exhausted (tried to allocate 30720 bytes) in /home/onlinele/public_html/wp-includes/class-simplepie.php on line 2723

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    This issue could be caused for various reasons.

    in a nutshell, the script that is being used requires more memory resources than is available on the server.

    if you have access to the servers php.ini then you can increase the amount of memory available by editing the value for memory_limit in that file.

    depending on the server spec, a good value for PHP 5 would be 64M but sometimes 128M will be needed, it depends on the resources your site is using.

    however, simply increasing the memory might not solve the issue if the script itself is not working correctly & might be consuming more memory than it requires.

    does this occur constantly whenever you visit your site, or only when you try and do a specific task? as simplepie is used for RSS/Atom feeds etc. you could disable those to test.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.