Fatal error for Classifieds 2.1.6

Hi,

I get the following message when trying to activate Classifieds latest version:

Plugin could not be activated because it triggered a fatal error.

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 5791625 bytes) in /var/www/ mydomain .com/public_html/wp-content/plugins/w3-total-cache/lib/W3/Cache/Apc.php on line 41

Any ideas? Besides - deactivating W3 site wide?

Cheers,

Johnny

  • Kimberly
    • Champion of Loops

    Johnny,

    I got a similar error when trying to install another plugin a while back.

    I actually uninstalled and reinstalled and it worked fine.

    The memory issue points to the server? so that's why I tried the fix, something got crossed in upload.

    Maybe deactivate W3 then activate Classifieds, then reactivate?

  • Jack Kitterhing
    • Code Norris

    Hi Johnny,

    I also had the same problem and basically what @KimberlyL said, here's what I done.

    Deactivate and deleted the classifieds plugin.

    Deactivate W3.

    Re-uploaded and activate and sort the settings for classifieds.

    Re-activate W3.

    Then all worked well for me, Let us know how this goes :slight_smile:

    Kind Regards
    Coding-Monkey.

  • johnnymestizo
    • HummingBird

    Unfortunately I cannot deactivate W3 without NGINX causing a whitescreen of death.

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 3159216 bytes) in /var/www/ my domain .com/public_html/wp-content/plugins/w3-total-cache/lib/W3/Cache/Apc.php on line 41

    Anyone have any idea how to make a work around? or why this is even happening?

    Cheers,

    Johnny

  • johnnymestizo
    • HummingBird

    Ok.

    Figured out stuff about nginx - then deactivated W3...!

    Installed classifeds

    Then tried to network activate and got the following message:

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 3151692 bytes) in /var/www/ my domain .com/public_html/wp-includes/functions.php on line 1038

    Do I not have enough memory now?

    Cheers

    Johnny

  • aecnu
    • WP Unicorn

    Greetings Johnny,

    We have our servers memory set up at 512 MB as you can see here just because of issues like this where the sum of the plugins installed exceeds the available ram memory.

    You should be able to set this higher in the php.ini file. Of course effective if your hosting package really has that much memory.

    Please advise.

    Cheers, Joe

  • johnnymestizo
    • HummingBird

    Set my wp-config.php to 512MB

    Still says, not enough memory...

    Will confirm if this is the real amount of mem avail.

    CONFIRMED:

    Using WP Overview and in my dashboard footer I have the following:

    Load 104.14M of 512M

    I still get the following error:

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 3304680 bytes) in /var/www/ my domain .com/public_html/wp-includes/functions.php on line 1038

    I need to role this out shortly. Any help much appreciated.

    Cheers,

    Johnny

  • aecnu
    • WP Unicorn

    Greetings Johnny,

    You have the right idea but shooting in the wrong direction.

    The memory control in not within the wp-config.php - ti is within the php.ini file.

    Please find attached a file that will tell you what you need to know about your php configuration including the current location of the php.ini file being executed.

    Load the file to the root of your domain and got to http://yourdomain.com/phpinfo.php and then on the page look up memory_limit and then you will see the real deal.

    Please advise.

    Cheers, Joe

  • johnnymestizo
    • HummingBird

    Hi

    I have found all the details above at my domain . com / info.php

    It was 128M...

    I have changed this to 512M

    Also, wordpress overview still states:

    Load 79.84M of 512M

    However, I still get the following error!

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 5598965 bytes) in /var/www/my domain . com /public_html/wp-includes/functions.php on line 1038

    W3 Total Cache is disabled.

    Any ideas?

    Johnny

  • aecnu
    • WP Unicorn

    Greetings Johnny,

    Thank you for your feedback it is appreciated.

    Unfortunately I am unable to replicate the issue, but all my servers are Apache plus I set the server php.ini to 512MB as a standard configuration.

    At this point I find it necessary to ask the lead developer of classifieds if he possibly has any advice/advise us as to what may be going on here because I am now at a dead end for trying to figure out what the problem may be.

    Cheers, Joe

  • Arnold
    • El Macho WP

    I don't think the problem is Classifieds per se. Somehing is using too much memory and exhausting the pool allocated, It's reporting 2Gigs available memory and that's a lot to be absorbed just by Wordpress.

    If you're on shared hosting there may be too many sites running on one server. If it's a VPS you may need to reconfigure or allow more memory,

    There are many places that memory limits can be placed in PHP, php.inim .htaccess, httpd.conf and it odesn't always reflect correctly by the time it gets to your program.

    You could try adding the line

    ini_set("memory_limit", “512M");

    to your wp_config.php file and see if that helps. If not it's time to get your hosting company involved to find out why it's choking.

  • johnnymestizo
    • HummingBird

    This is from Ravi:

    The error normally occurs when PHP tries to process a big database
    records or when importing or exporting. To solve the error, there are two resolutions. One is to change and increase the memory limit of the particular PHP script by adding or including an additional line at the top of the script:

    ini_set(”memory_limit”,”16M”);

    You can assign the memory limit to any amount you like by changing the 16M to other number, such as 12M or 24M. 16M will set the memory limit to 16 megabytes. If this doesn’t work and the PHP error still appearing, increase the memory limit until the PHP scripts running perfectly or the limit of your system hardware.

    To change the memory allocation limit permanently for all PHP scripts running on the server, modify the PHP.INI configuration file of the server (location depending on your OS and installation method). Search for memory_limit after opening the file in an editor. If the memory_limit doesn’t exist, add the following line. If it’s there, modify the value of the memory_limit:

    memory_limit = 12M

    The 12M sets the limit to 12 megabytes (12582912 bytes). Change to the value you desirable.

    An alternative way is to modify your PHP scripts that generate the error for more efficiency and better data handling.

    http://wordpress.org/support/topic/fatal-error-allowed-memory-size-5

    Is there any way for me to edit the files of classifieds so I can get this installed. As I have done the above. The good news, is that I have classifieds running on a single site test install. The bad news is that on my multisite it is not installing. I really just need help to get classifieds installed on my big install.

    Cheers,

    Johnny

  • johnnymestizo
    • HummingBird

    Ok.

    I have deleted all core plugins.

    deactivated everything (except domain mapping)

    installed classifieds

    reinstalled all core plugins.

    classifieds appears to be working now !

    512MB of memory, the same plugins... i have no idea why wordpress kept crapping out...

    Funny - all the forum posts I was reading, they called wordpress, error press. Sometimes it is true!

    Thanks for the help.

    Johnny

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.