Fatal Error Notice Trying To Re-Activate Plugin

Hi Support,

I am having an urgent plugin error message on my site after deactivating and then reactivating a plugin, which is being used for my home page. My site is using MarketPress/GridMarket and this is an urgent support request as my home page is now disconfigured as a result of this issue.

I was having an editing problem in the lower half section of the page where the PB editor would not open for some reason, so I decided to deactivate the plugin and then reactivate it, to see if it would solve the issue. I haven’t seen this type of issue before but looks like some tech problem that may or may not be connected to my hosting.

Would appreciate assistance with this issue.

Thanks

James

The error message appears below:

Plugin could not be activated because it triggered a fatal error.

Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 786432 bytes) in /home4/superhot/public_html/www.hypnosismultimedia.com/wp-content/plugins/profit_builder/functions/shortcode_list.php on line 3360

  • Vinod Dalvi
    • WP Unicorn

    Hi James,

    Thank you for your question.

    I accessed admin area of your site using support staff access and found the MarketPress plugin is activated fine.

    Is the issue resolved now?

    It seems from your shared error message that the error is displayed because of low memory allocated to PHP on your server compared to the plugins/functionality you are using on your site.

    Could you please try Increasing memory allocated to PHP using the information provided on the following page?

    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    http://docs.woothemes.com/document/increasing-the-wordpress-memory-limit/

    Best Regards,

    Vinod Dalvi

  • James
    • Flash Drive

    Hi Vinod,

    Thanks for reply to this thread and your suggested links. The issue is not resolved yet as I am unable to locate the wp-config-php. I have tried the editor but can only see all the mp-php lists and have tried in my cPanel for it.

    Unable to locate current memory php file!

    Would you be able to locate the config-php for editing please, the home page is where the issue is observable.

    Thank you for your attention to this issue,

    Regards

    James

  • calvinrogercanas
    • New Recruit

    Hello James,

    Hope you’re well!

    You can’t edit the wp-config.php inside your admin dashboard. You need to use FTP software then connect using your site’s ftp credentials(your hosting provider can give this to you) then navigate to /public_html/

    and finally you can see the wp-config.php.

    I am also happy to assist you to do this task for you. Just let me know! :slight_smile:

    Best Regards,

    Calvin

  • James
    • Flash Drive

    Hi Calvin,

    Thanks for the reply and your comments. I have had a look in hosting and the only two public-html files I find seem to be empty. I have searched but still unable to locate wp-config-php!

    If you are able to assist that would be great…please provide area for me to supply hosting login for you, I would like to set memory to max available limit please.

    Thanks

    James

  • James
    • Flash Drive

    Hi Calvin,

    Quick updaate: I have found the wp-config-php and here is copy!..can’t see where to update memory though!

    Can you advise thanks?

    James

    <?php

    /**

    * The base configurations of the WordPress.

    *

    * This file has the following configurations: MySQL settings, Table Prefix,

    * Secret Keys, WordPress Language, and ABSPATH. You can find more information

    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing

    * wp-config.php} Codex page. You can get the MySQL settings from your web host.

    *

    * This file is used by the wp-config.php creation script during the

    * installation. You don’t have to use the web site, you can just copy this file

    * to “wp-config.php” and fill in the values.

    *

    * @package WordPress

    */

    // ** MySQL settings – You can get this info from your web host ** //

    /** The name of the database for WordPress */

    define(‘DB_NAME’, ‘superhot_wrdp7’:wink:;

    /** MySQL database username */

    define(‘DB_USER’, ‘superhot_wrdp7’:wink:;

    /** MySQL database password */

    define(‘DB_PASSWORD’, ‘5LA7qUbcyhUE’:wink:;

    /** MySQL hostname */

    define(‘DB_HOST’, ‘localhost’:wink:;

    /** Database Charset to use in creating database tables. */

    define(‘DB_CHARSET’, ‘utf8’:wink:;

    /** The Database Collate type. Don’t change this if in doubt. */

    define(‘DB_COLLATE’, ”:wink:;

    /**#@+

    * Authentication Unique Keys and Salts.

    *

    * Change these to different unique phrases!

    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}

    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.

    *

    * @since 2.6.0

    */

    define(‘AUTH_KEY’, ‘@j?ipQ1nR,yuuCW@Uhypnosismultimedia.comAS-{%gQEpSr_+<dyb+>:Yd#nWbetyh~4rmMUap4Q6rZEcZy’:wink:;

    define(‘SECURE_AUTH_KEY’, ‘+hOIBXnJ~C;ftmT([CA|]_wDShypnosismultimedia.comG<K?#S8{H>//EaLy7]h:jhRfj.K=Usg#g&$9+ox’:wink:;

    define(‘LOGGED_IN_KEY’, ‘c8K?-u_wU{BZ2yHK_sbOo1@?!hypnosismultimedia.com}H<`PM%7^l6VJTY,~DSOJ,zCtVI@Ym$WZi1@5×5’:wink:;

    define(‘NONCE_KEY’, ‘s5,9YV+%:+HFX#l~ %RE`AZ/phypnosismultimedia.comUzn<&<R%71t-|[H-L+}AtN9/thH&dMcVM8WN|Q}’:wink:;

    define(‘AUTH_SALT’, ‘KUEIq@~d.Tk+~t>1:HS9$8G_*hypnosismultimedia.comzG,jcuq2l=7l#KE[-1c)QW3a{LwGi-kwhRVP&]g’:wink:;

    define(‘SECURE_AUTH_SALT’, ‘;0GoKVCGWIZh:YOa*h[]-T&Dihypnosismultimedia.comnp=:iQ;z$>OkEYNi2@Y`|5-c|n:Jb #}97E?LX7’:wink:;

    define(‘LOGGED_IN_SALT’, ‘we3RP{hVolwbVh-((L%LEcHKlhypnosismultimedia.com[IaA9<bDvi`h/M:3U7xK8S]A|.Q,2$|*jcOqWNB’:wink:;

    define(‘NONCE_SALT’, ‘~<MckLITBiGaIV)497^JDbe-)hypnosismultimedia.comG:*}/Prup?HeQMLNLz2kG~d/306X7Noin@gGh7+’:wink:;

    /**#@-*/

    /**

    * WordPress Database Table prefix.

    *

    * You can have multiple installations in one database if you give each a unique

    * prefix. Only numbers, letters, and underscores please!

    */

    $table_prefix = ‘wp_’;

    /**

    * WordPress Localized Language, defaults to English.

    *

    * Change this to localize WordPress. A corresponding MO file for the chosen

    * language must be installed to wp-content/languages. For example, install

    * de_DE.mo to wp-content/languages and set WPLANG to ‘de_DE’ to enable German

    * language support.

    */

    define(‘WPLANG’, ”:wink:;

    /**

    * For developers: WordPress debugging mode.

    *

    * Change this to true to enable the display of notices during development.

    * It is strongly recommended that plugin and theme developers use WP_DEBUG

    * in their development environments.

    */

    define(‘WP_DEBUG’, false);

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */

    if ( !defined(‘ABSPATH’:wink: )

    define(‘ABSPATH’, dirname(__FILE__) . ‘/’:wink:;

    /** Sets up WordPress vars and included files. */

    require_once(ABSPATH . ‘wp-settings.php’:wink:;

  • James
    • Flash Drive

    Hi Support,

    I have added the memory limit code as directed but still no change to the site: I am continuing to get the following Fatal Error message when I try to re-activate the Profit Builder plugin, which is responsible for my home page.

    “Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 786432 bytes) in /home4/superhot/public_html/www.hypnosismultimedia.com/wp-content/plugins/profit_builder/functions/shortcode_list.php on line 3360”

    The wp-config-php now looks like:

    <?php

    /**

    * The base configurations of the WordPress.

    *

    * This file has the following configurations: MySQL settings, Table Prefix,

    * Secret Keys, WordPress Language, and ABSPATH. You can find more information

    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing

    * wp-config.php} Codex page. You can get the MySQL settings from your web host.

    *

    * This file is used by the wp-config.php creation script during the

    * installation. You don’t have to use the web site, you can just copy this file

    * to “wp-config.php” and fill in the values.

    *

    * @package WordPress

    */

    // ** MySQL settings – You can get this info from your web host ** //

    /** The name of the database for WordPress */

    define(‘DB_NAME’, ‘superhot_wrdp7’:wink:;

    /** MySQL database username */

    define(‘DB_USER’, ‘superhot_wrdp7’:wink:;

    /** MySQL database password */

    define(‘DB_PASSWORD’, ‘5LA7qUbcyhUE’:wink:;

    /** MySQL hostname */

    define(‘DB_HOST’, ‘localhost’:wink:;

    /** Database Charset to use in creating database tables. */

    define(‘DB_CHARSET’, ‘utf8’:wink:;

    /** The Database Collate type. Don’t change this if in doubt. */

    define(‘DB_COLLATE’, ”:wink:;

    /**#@+

    * Authentication Unique Keys and Salts.

    *

    * Change these to different unique phrases!

    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}

    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.

    *

    * @since 2.6.0

    */

    define(‘AUTH_KEY’, ‘@j?ipQ1nR,yuuCW@Uhypnosismultimedia.comAS-{%gQEpSr_+<dyb+>:Yd#nWbetyh~4rmMUap4Q6rZEcZy’:wink:;

    define(‘SECURE_AUTH_KEY’, ‘+hOIBXnJ~C;ftmT([CA|]_wDShypnosismultimedia.comG<K?#S8{H>//EaLy7]h:jhRfj.K=Usg#g&$9+ox’:wink:;

    define(‘LOGGED_IN_KEY’, ‘c8K?-u_wU{BZ2yHK_sbOo1@?!hypnosismultimedia.com}H<`PM%7^l6VJTY,~DSOJ,zCtVI@Ym$WZi1@5×5’:wink:;

    define(‘NONCE_KEY’, ‘s5,9YV+%:+HFX#l~ %RE`AZ/phypnosismultimedia.comUzn<&<R%71t-|[H-L+}AtN9/thH&dMcVM8WN|Q}’:wink:;

    define(‘AUTH_SALT’, ‘KUEIq@~d.Tk+~t>1:HS9$8G_*hypnosismultimedia.comzG,jcuq2l=7l#KE[-1c)QW3a{LwGi-kwhRVP&]g’:wink:;

    define(‘SECURE_AUTH_SALT’, ‘;0GoKVCGWIZh:YOa*h[]-T&Dihypnosismultimedia.comnp=:iQ;z$>OkEYNi2@Y`|5-c|n:Jb #}97E?LX7’:wink:;

    define(‘LOGGED_IN_SALT’, ‘we3RP{hVolwbVh-((L%LEcHKlhypnosismultimedia.com[IaA9<bDvi`h/M:3U7xK8S]A|.Q,2$|*jcOqWNB’:wink:;

    define(‘NONCE_SALT’, ‘~<MckLITBiGaIV)497^JDbe-)hypnosismultimedia.comG:*}/Prup?HeQMLNLz2kG~d/306X7Noin@gGh7+’:wink:;

    /**#@-*/

    /**

    * WordPress Database Table prefix.

    *

    * You can have multiple installations in one database if you give each a unique

    * prefix. Only numbers, letters, and underscores please!

    */

    $table_prefix = ‘wp_’;

    /**

    * WordPress Localized Language, defaults to English.

    *

    * Change this to localize WordPress. A corresponding MO file for the chosen

    * language must be installed to wp-content/languages. For example, install

    * de_DE.mo to wp-content/languages and set WPLANG to ‘de_DE’ to enable German

    * language support.

    */

    define(‘WPLANG’, ”:wink:;

    /**

    * For developers: WordPress debugging mode.

    *

    * Change this to true to enable the display of notices during development.

    * It is strongly recommended that plugin and theme developers use WP_DEBUG

    * in their development environments.

    */

    define(‘WP_DEBUG’, false);

    define(‘WP_MEMORY_LIMIT’, ‘256M’:wink:;

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */

    if ( !defined(‘ABSPATH’:wink: )

    define(‘ABSPATH’, dirname(__FILE__) . ‘/’:wink:;

    /** Sets up WordPress vars and included files. */

    require_once(ABSPATH . ‘wp-settings.php’:wink:;

    Would appreciate any suggestions thanks,

    James

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    I see the memory_limit is actually working in the system info page of the dashboard plugin it says memory_limit is 256M. So i’m not sure why you are seeing that error now.

    You may need to ask your host about this, to see if they are setting any restrictions at server level on memory_limit

    You could possibly try increasing post_max_size to 256M too, though this would have to be done in php.ini, i’m not sure how to do this on hostgator exactly, so you may need to ask them about it.

    Hope this helps

  • James
    • Flash Drive

    Hi again Vaughan,

    Thanks for your input, this is all very frustrating!..seem to just get going before another issue arises. Will get on to hostgator to see if they have a solution!..will let you know how I get on.

    Thanks again!

    James

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.