Fatal Error when accessing admin section of subsite

I have a client who is receiving a fatal error when logging into their site. I am also encountering the error when I try to access their admin section when already logged in as the super admin. Here’s the error:

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 1048576 bytes) in /home/igitaoj9/public_html/wp-includes/functions.php on line 443

Also, here’s the section of the functions.php file that surrounds line 443:

/**
* Serialize data, if needed.
*
* @since 2.0.5
*
* param string|array|object $data Data that might be serialized.
* @return mixed A scalar data
*/
function maybe_serialize( $data ) {
if ( is_array( $data ) || is_object( $data ) )
return serialize( $data );

// Double serialization is required for backward compatibility.
// See https://core.trac.wordpress.org/ticket/12930
// Also the world will end. See WP 3.6.1.
if ( is_serialized( $data, false ) )
return serialize( $data );

return $data;
}

Client site is at http://newarknaz.org

I’m going in now to open up support access to my network.

  • Mark
    • Site Builder, Child of Zeus

    I was getting a blank screen when accessing the admin section on another one of my subsites. I enabled WP_debug and then I got the following errors:

    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.0.) in /home/igitaoj9/public_html/wp-includes/functions.php on line 3996

    Warning: Cannot modify header information – headers already sent by (output started at /home/igitaoj9/public_html/wp-includes/functions.php:3996) in /home/igitaoj9/public_html/wp-content/plugins/sg-cachepress/class-sg-cachepress.php on line 335

    Warning: session_start(): Cannot send session cache limiter – headers already sent (output started at /home/igitaoj9/public_html/wp-includes/functions.php:3996) in /home/igitaoj9/public_html/wp-content/plugins/pro-sites/pro-sites-files/lib/ProSites/Helper/Session.php on line 29

  • Alex Stine
    • System Administrator

    Hello Mark

    Hope you are well today and thanks for granting access! :slight_smile:

    I just checked your site and I could see that the PHP memory_limit seemed to be fine. What caught my eye is seeing your max_execution_time at 0. Could you please try increasing your max_execution_time to a value such as 300 or the highest allowed value by your host if you cannot do 300? You can do this by following this guide.

    https://premium.wpmudev.org/blog/increase-memory-limit/

    Please let me know how it goes.

    Cheers,

    Alex :smiley:

  • Mark
    • Site Builder, Child of Zeus

    I’m also seeing some interesting things on my server via FTP. My wp-admin folder contains several new directories. Some of them are website urls like http://www.apple.com or http://www.facebook.com, while others appear to be code in the directory name.

    Also, my wp-includes folder has several odd directories, like one named:

    n .current, .fusion-portfolio-post”,loading:{finishedMsg:js_local_vars.infinite_finished_msg,msg:jQuery(‘<div class=”fusion-loading-container fusion-clearfix”><div class=”fusion-loading-spinner”><div class=”fusion-spinner-1″><

  • Mark
    • Site Builder, Child of Zeus

    I ran a defender scan, which told me that the default-constants.php file has been modified from its original version. When I clicked on the filename, it brought me to a patch section where I could see the edits. The changes were all in reference to the memory limits.

  • Hoang Ngo
    • Code Slayer

    Mark,

    I hope you are well today and I’m sorry for the issue.

    For now, I don’t have any clue to determine what’s causing it :slight_frown:. I need more information for further debug. Can you please send in:

    – Mark to my attention – ATTN: Hoang Ngo

    – Link back to this thread

    – Include admin/network access

    – Include FTP

    – Include any relevant URLS for your site

    On the contact form, select “I have a different question”, this ensures it comes through and gets assigned to me.

    Thanks!!.

    Best regards,

    Hoang

  • Alex Stine
    • System Administrator

    Hello Mark

    Hope you are well today!

    I’m sorry, but I could not find an email from you. I also had our email staff look in to this and they could not find one either. :slight_frown: Could you please try emailing the information directly to the following address?

    contact@wpmudev.org

    Please send the information that Hoang Ngo asked for in this reply.

    https://premium.wpmudev.org/forums/topic/fatal-error-when-accessing-admin-section-of-subsite#post-1181575

    I’m sorry for the inconvenience.

    Thanks,

    Alex :smiley:

  • Mark
    • Site Builder, Child of Zeus

    I’ve left Defender uninstalled for some time now, but after the cloud flare leaks, I decided to activate it again. Everything seems to be working fine now, so I’m marking this as resolved.

    Thank you so much!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.