Fatal Error when I try to network activate

I get a fatal error every time I try to network activate the Cloner plugin. Parse error: systems error, unexpected T_PAAMAYIM_NEKUDOTAYIM.

Any ideas?

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi there, Josh!

    This link explains the error, and it makes me laugh: http://phpsadness.com/sad/1

    It means there's an unexpected :: in the code. Is there more to the error message, by chance? Cloner activates and deactivates okay for me, so that leads me to think it might be a third party interfering here.

    Have you done any conflict troubleshooting?

    Any additional clues could help track this down. Thanks!

  • Josh
    • Site Builder, Child of Zeus

    That's what I get. I will check out the link and do some more troubleshooting. Thanks!

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home3/minatio1/public_html/wp-content/plugins/cloner/copier/copier.php on line 506

  • Josh
    • Site Builder, Child of Zeus

    Ari,

    Now I'm second guessing what I did the other day to fix it. I have the same line 506 on my install...Whatever I did, there was a '::' where there should have been a '='. I wish I remembered more, but it is working for me now.

  • Josh
    • Site Builder, Child of Zeus

    Not so much a plea for help, but is there a known problem with Cloner? My site just gave the White Screen of Death. I was troubleshooting with my host, and once I deactivated Cloner, all was well. I love the PU, but it has given me several panic attacks just this week. I'm admittedly not smart enough to tell you what exactly it is doing, but I just know it gives 500 Internal Server Errors or the WSOD. No matter, I uninstalled it, and will use it again when I need to clone some sites. Once I know the fix, it's totally worth it. Just wanted to mention that something isn't working right. Could be my theme too...

  • Ignacio
    • HummingBird

    Hi Josh, This error is usually because you have an older PHP version. But as @aristath said the 506 line is a simple line. Have you got the latest version of Cloner (1.4.1)? I added older PHP versions integration in the last one.

    Another solution would be to update PHP.

    Regards.
    Ignacio.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.