Fatal Error when installing plugin

Hello,

I'm upgrading from an older version

Fatal error: Cannot redeclare class Wiki in /var/www/vhosts/ca.lp.org/html/wp-content/plugins/wiki/wiki-include.php on line 11

I also get a message that says the /wiki/ directory already exists. Anybody know what can be done. Currently I have wiki light installed and I'm trying to install the full version.

  • aecnu
    • WP Unicorn

    Greetings freebook,

    Welcome to WPMU Dev!

    I totally agree with coding-monkey about deleting the old free version and then you should be able to install the full version without error.

    There are great differences between the two versions and this is probably why you receive the error.

    Please advise as to how this comes out.

    Cheers, Joe :slight_smile:

  • freebook
    • New Recruit

    Ok, so I deleted the wiki plugin so that it doesn't appear anywhere in the plugin dashboard. Then when I go to install the full version of wiki, it tells me the following:

    ******
    Installing the plugin…

    Destination folder already exists. /var/www/vhosts/ca.lp.org/html/wp-content/plugins/wiki/

    Plugin install failed.

    *******

    So it seems when the plugin is deleted it leaves the folder??? Help!

    -F

  • aecnu
    • WP Unicorn

    Greetings freebook,

    It has become obvious from you last two posts that you are trying to manage everything using the dashboard and not using an FTP program to FTP in and get the job done.

    I do not believe anywhere on WPMU Dev does it mention NOT FTP'ing in to install and manage plugins.

    The Dashboard upload and plugin management definitely has its limitations and this is why we do not tell about using it within our instructions.

    Please advise if I am right about to date you are not using FTP --> then everything will start to make sense that you have been telling about.

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.