Fatal Error when trying to access group forums in buddypress…

Our web hosting company just transferred us over to a new server, and now users are getting a fatal error when trying to access the group forums in our online community.

Here is the error: Fatal error: Call to undefined function bb_get_id_from_slug() in /home/paychec4/public_html/bravegirlsclub.com/blog/wp-content/plugins/buddypress/bp-forums.php on line 206

Does anyone know how to fix this? Will reinstalling buddypress or redoing the forums setup cause all the data in the forums/groups to be lost?

  • Philip John
    • DEV MAN’s Apprentice


    First things to check are;

    – that all the files are present

    – they all have the correct permissions

    – the owner/group settings are correct (this should be in a column alongside permissions in your file manager or FTP program)



  • DDV
    • Design Lord, Child of Thor

    I reckon it’s a plugin conflict. Have you installed any new ones since the move?

    The BuddyPress Template pack causes this one too. But looking at your site’s source code it looks like you’re using a BuddyPress compatible theme (bp-fun-child) so the template pack shouldn’t be active on the site that’s causing the error.

  • DDV
    • Design Lord, Child of Thor

    Temporarily configure BuddyPress to use a different page for the forum. If the forum works as a different page you will know the software is not at fault.

    Whether it works from a different page or not, swap the page back and check it again. If it still doesn’t work in its regular page, disable then re-enable BP. Do likewise with the forum software (bbPress) then recheck the settings.

    As a last resort, reinstall the software. You might get away with just uploading and extracting the zip files to /wp-content/plugins/ to overwrite the old files. All data will be in your site’s database so make a backup first if you’re worried about losing it. The data shouldn’t be affected by reinstalling the software but you can never be too careful with a large and active forum.

    As a general tip: when you backup your database (I’ll assume you use PhpMyAdmin), make sure to optimize and repair its tables first then change the export setting that reads “INSERT” to “REPLACE” (this makes it easier to restore it) then download/export the file, extract it if it’s compressed and confirm the extracted file is approximately the same size as the database on your server (PhpMyAdmin tells you the database size at the bottom-right-hand-side of the table when you browse it). Some server’s time-out prematurely during the export process hence the need to compare the download size. You’ll also need to check the maximum database file upload (import) size to ensure your download is smaller than the maximum upload size (the database can be exported in segments if needed).

    You could test the exported database before you reinstall the software. Do this by creating a new database in cPanel and importing the downloaded database into it. Then change the database name, database username and database password in wp-config.php to reflect the copy database’s login credentials (back up the original details first!). If the site works with the new database you will know the new database exported and imported properly. You could then quickly swap to this backup database if reinstalling BuddyPress goes wrong.

  • Jeff
    • Design Lord, Child of Thor

    Thanks so much for all of your input… turns out all that I needed to do was re-do the setup for the forums pointing it to the old bb-config.php file.

    After completing that step, all the forums worked again without a hitch and no data was lost.

  • tbennett04
    • Site Builder, Child of Zeus

    I’m trying to figure out something similar. I’ve disabled plugins, reinstalled (which fixes bb-config.php), deleted the db table bp_groups_groupmeta and tried the check/uncheck to turn the forum on and off. I’ve manually deleted topics from the backend as well before trying to create new ones.

    I keep getting this stupid error: There was an error when creating the topic

    I get no errors in my logs :slight_frown:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.