Fatal Error When Trying To Edit A Page

Hi guys,

I've recently installed and configured:

1. Snapshot
2. Defender
3. Smartcrawl
4. Hummingbird

And now when I try to edit a page I get this error message:

Fatal error: Uncaught Error: Class '' not found in /home/wwwnectonfestiva/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/aws/AWSSDKforPHP/config.inc.php:50 Stack trace: #0 /home/wwwnectonfestiva/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/aws/AWSSDKforPHP/sdk.class.php(1510): include_once() #1 /home/wwwnectonfestiva/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/aws/index.php(12): require_once('/home/wwwnecton...') #2 /home/wwwnectonfestiva/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination.php(86): include('/home/wwwnecton...') #3 /home/wwwnectonfestiva/public_html/wp-content/plugins/snapshot/snapshot.php(260): Snapshot_Model_Destination::load_destinations() #4 /home/wwwnectonfestiva/public_html/wp-includes/class-wp-hook.php(298): WPMUDEVSnapshot->snapshot_init_proc('') #5 /home/wwwnectonfestiva/public_html/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(NULL, Array) #6 /home/wwwnectonfestiva/public_html/wp-includes/ in /home/wwwnectonfestiva/public_html/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/aws/AWSSDKforPHP/config.inc.php on line 50

Any ideas what's gone wrong?

The rest of the admin panel seems to be working fine.

Regards,

Ash

  • Denitsa

    Hello Ash,
    I hope you're having a beautiful day!

    When I accessed your site and tried to edit a page I got a 404 not found error and not the error messages you've reported. Can you outline some steps here in order to reproduce this exact error?

    I suspected a conflict with the Fusion Builder plugin, and when I briefly deactivated it all seemd well. When I activate it again, sometimes it works and sometimes I get the " 404 page not found" or the following error:

    It looks like an issue of memory limit and maximum execution time. Please try to increase memory limit and maximum execution time. You can use the following as a guide on how to do that:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    Let me know how it goes!

    Cheers,
    Denitsa

  • Ash

    Hi Denitsa,

    Thanks for your reply.

    I tried to increase the memory limit (even though it's already 256MB) and this completely destroyed my website. I've had to upload a backup to get things up and running again.

    I've been doing some testing and every time I activate any of the following plugins (all WPMU) my website breaks and I cannot edit pages.

    - Snapshot
    - Defender
    - Hummingbird
    - Smush Pro

    This time however, there is no error message, just a blank white screen.

    I use the same theme (Avada) and the same server (Siteground) using exactly the same plugins for all of my websites, but I've never come across this issue before.

    Your assistance would be greatly appreciated.

    Regards,

    Ash

  • Sajid

    Hello Ash,
    Hope you are doing good today :slight_smile:

    Thanks for enabling support staff access. During basic troubleshooting, I found that the issue is with Fusion Builder plugin. Once I deactivate it, the edit page works just fine.

    It appears, that these plugins required a good amount of resources to function all together. I see the memory is set to 256 Mb, could you please try to further increase the limit.

    Along with memory limit, please try to increase Maximum Execution time. It is currently set to 45 seconds, as far as I know, you can set it upto 120 seconds on siteground.

    Also, the upload_max_filesize and post_max_size are set to very low. The 404 error mentioned by Denitsa above is mostly likely due to this limitation. So please try to increase these values too.

    If you are not sure then take a look at following blog post on how to increase limits:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.