Fatal Error with Upfront & Spirit themes

Fatal error: Access level to Upfront_UploadHandler::generate_response() must be public (as in class UploadHandler) in /home/j93df0x5apwc8q/public_html/wp-content/themes/upfront/library/media/class_upfront_upload_handler.php on line 62

  • antKat

    Hi Nastia,
    It's a mess! I tried ftp both upfront and spirit and still had problems. Then I deleted them both via ftp.
    At that point I could at least get to the dashboard. I then updated all of my plugins including the WPMUdev dashboard. At that point things looked like they were possibly ok except that I didn't have the theme back. So I then made a stupid mistake and tried installing the spirit theme from the WPMUdev dashboard. It didn't work. I cant get anywhere from the main dashboard without getting this fatal error

    Fatal error: Access level to Upfront_UploadHandler::generate_response() must be public (as in class UploadHandler) in /home/j93df0x5apwc8q/public_html/wp-content/themes/upfront/library/media/class_upfront_upload_handler.php on line 80

    So I then went to delete the theme from my server via ftp and it is NOT IN THE THEMES folder!!! Where could your dashboard have installed it to???

    I have granted access. The theme is suppose to be active on our main site vitalitytoolbox

  • Nastia

    Hello antKat, I hope you are doing well today!

    My sincerest apologies for the delayed response.

    I tried to install the plugin, and I confirm the same behavior.

    Would you please enable WordPress debugging. To enable WordPress debugging, please put the following lines in the wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    All the errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Would you please send to us your credentials so I could check?
    You can send credentials by using our secure contact form https://premium.wpmudev.org/contact/

    - Mark to my attention, the subject line should contain only: ATTN: Nastia
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls

    Select “I have a different question” for your topic.

    May I ask for permission to disable the plugins?

    We are waiting for your response!

    Kind Regards,
    Nastia

  • Nastia

    Hello @antKat!

    Thank you for sending the credentials. Sorry to hear that the captcha wasn't working. Please if you have this issue next time, clear the browser from cache and cookies.

    I've re installed Sprit and Upfront on your installation and found out that the errors was caused because of the conflict with a plugin. Turns out the CKEditor WYSIWYG for Gravity Forms is not compatible with Upfront.

    I've confirmed the same on my installation and I've flagged a second level support here, so they can have a look. For now I disabled the plugin from your installation. If you enable it along with Upfront theme it will cause a 500 error

    Let us know if you require any further assistance!

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.