FB Login stuck on "Please, wait"

Hi there!

Whenever i try to login using Facebook, i get the popup window, enter my FB credentials, the popup closes and i then see the spinning wheel and "please, wait" message displayed on the single event page. However, nothing else happens after that, meaning it does not display the succesful registration message event though login has been successful (if i refresh the page i see the "You haven't paid for this event" message).
Anything i should do to fix that?

Thanks!

  • Kimberly

    tagada,

    Hi and Welcome to WPMUdev forums!

    I'd love to be of help, let's just get a few more details :slight_smile:

    Are you using our Ultimate Facebook Plugin for login? If not then please let me know which you are using.

    I'm assuming that you are using our Events+ plugin as well?

    Both Events and Ultimate Facebook have a checkbox that says: My pages already load scripts from Facebook
    You will need to ensure that you do NOT have your API in both pluigns. This means that one should have your full API access (ideally Ultimate Facebook) and you would check the box that says you are already using Facebook scripts in the other (Events+).

    This should help to clear up your issue :slight_smile: If not please re-open and let me know!

    Best,

    Kimberly

    If this thread is not resolved because the suggested action did not work or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

  • aecnu

    Greetings tagada,

    Just checking in to see where we are with this ticket and if not resolved please provide the URL to the site so that we can check the log in fist hand.

    In addition though you stated the use of both the Ultimate Facebook plugin and Comments plus plugin, you did not indicate which one you are specifically having trouble with and therefore this ticket has gone unclassified.

    Please advise.

    Cheers, Joe

  • tagada

    Hi Aecnu,

    Thanks for checking up on this thread, i thought it got buried in the limbos :slight_smile:

    Actually i have problems with both plugins:

    Ultimate Facebook somehow always logs me in with my wordpress admin account, even though both account's emails are different.

    Events + stays stuck on the "please, wait" spinning wheel when i try to book an event using my Facebook account. I never get to the "succesful registration" message although the facebook login has been successful (if i refresh the page i can see the "You haven't paid for this event" message).

    You can check my Ultimate Facebook install here:
    http://fa.lecteurmp3.eu/wp-admin

    And Events + here:
    http://fa.lecteurmp3.eu/schedule/2012/04/asheville-nc-minute-weekend-retreat/

  • Hakan

    Hi tagada,

    First things first, your theme does not obey the rules of proper jQuery usage.

    Please search and find these line in your theme:

    var $j = jQuery.noConflict();
    $j(document).ready(function() {

    Replace two lines it with this one line:

    jQuery(document).ready(function($j) {

    And yes, it means removing the first line, as Wordpress already uses jQuery in "noconflict" mode.

    I don't say that this will fix everything, but you need to make this change anyhow to make your theme compatible to Wordpress directives.

    Please try this and share the results with us.

    Cheers
    Hakan

  • aecnu

    Greetings tagada,

    I review of the this ticket and the a developer trying to assist, it is now time to get heavy duty on this issue to possibly get it resolved.

    Lets make sure you have the latest versions of everything before we go knee deep into troubleshooting.

    WordPress 3.3.2?
    Multisite or Solo?
    Buddy Press 1.5.5?
    Ultimate Facebook 2.0.1?

    Once we have established that all versions are current .....

    Now it is time to go into full blown trouble shooting mode because it appears there may be some conflict here and one way to find out conclusively.

    Standard plugin trouble shooting protocol involves deactivating all plugins except the plugin in question and then see if the issue still exists. If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns.

    Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting. You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe

  • aecnu

    Greetings tagada,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.