FB plugin was working fine. Updated the plugin and now have

FB plugin was working fine. Updated the plugin and now have this warning

"Please, enter correct Facebook API settings and make sure Facebook app is public"

I'm logged into FB, API settings are correct and the app is public...

Please advise