FB problem and a sugestion

First of all great plugin. But when I try to use facebook to login nothing pops out just for Facebook. I checked and unchecked the JS option and nothing.

It would be nice if you had an option to put a twitter, facebook or google icon next to the username to show how they login and a link to their account.

  • DavidM
    • DEV MAN’s Mascot

    Hi juanmanuel and welcome to WPMU DEV!

    Hmm, if nothing at all pops up that seems to suggest a javascript issue but that would be easy to tell in viewing the site. If possible, can we get a link to check that out?

    Other than that, are you sure you've got the Facebook App settings setup properly?

    Thanks,
    David

  • Arom77
    • Froggy

    I had the same problem so I deactivated it for the moment.

    (Right now I just checked the button for Ultimate Facebook and saw it doesn't work anymore (same problem : when I try to use facebook to login nothing pops out). It used to work before so I don't know what the problem is all about.)

  • DavidM
    • DEV MAN’s Mascot

    Hi juanmanuel,

    You should see a comment which I posted after logging in through Facebook on your site. It does seem to work, perhaps it's a browser caching issue on your end?

    Could you try commenting through a different browser or clearing your browser cache?

    Thanks,
    David

  • DavidM
    • DEV MAN’s Mascot

    @Thorsten, I see the issue on your site, it's yielding an error in the console on Chrome:
    Uncaught Error: OAuth2 specification states that 'perms' should now be called 'scope'. Please update.

    Just to check though, in your case, are you using any other Facebook plugins? Also, is your App on Facebook properly setup?

    Thanks,
    David

  • Vladislav
    • Dead Eye Dev

    Hi,

    Thank you for sharing the links - debugging such issues is fiddly, and having an opportunity to actually see for myself what's happening is really helpful.

    @Thorsten, it appears there are multiple div#fb-root elements on your page. This can be solved by going to your Comments Plus plugin settings, and checking the "Skip loading Facebook javascript" box, since your page already has the javascript it needs to connect to Facebook. Can you please try that and see if it helps?

    @juanmanuel, your situation is similar, but still a bit different, as you already include the javascript from Facebook (in your likebox widget), but unfortunately it doesn't include the entire initialization Comments Plus needs. Can you please try temporarily disabling your likebox widget and *unchecking* the "Skip loading Facebook javascript" box in Comments Plus settings, so the plugin loads what it needs itself? If that helps, you can bring your widget back in, but just delete everything except the XFBML tag - since Comments Plus will bring the FB scripts in your page, the XFBML tag is all you need.

    @Arom77, if you're already using Ultimate Facebook, your page should already have all the scripts from Facebook it needs. Can you please try checking the "Skip loading Facebook javascript" box in Comments Plus settings and see if it helps?

  • Tee
    • The Crimson Coder

    @DavidM @VeBailovity
    Very cool Plugin!

    Yes, you both are right. I'm using a plugin called Simple Facebook Connect (http://ottopress.com/wordpress-plugins/simple-facebook-connect/).

    After deactivating that plugin everything works fine. Unfortunately it doesn't help to skip loading Facebook javascript. I have to deactivate Simple Facebook Connect. So I have to decide for one ore another. Any chance you investigate the compatibility to the Simple Facebook Connect plugin? It works very well!

    Cheers
    Thorsten

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.