Featured Image hangs on save

Hello, I hope someone can help me with my issue as I have tried everything from disabling all plugins to changing themes. My problem is that when I try to set a featured image it just hangs on saving and never stops. My website is http://www.pittsburgh-blitz.com

Also I have tried to update wordpress, use a default theme, run repair database, etc., and nothing helps to fix the issue. Does anyone have any ideas to help?

  • digitsoft
    • The Crimson Coder

    Go Stillers! Yup…originally from the burgh…

    Alright…on to your problem…

    It’s most likely a memory or timeout issue, so put this file in the root of your site and open it in a browser:


    Post the values for these:

    memory_limit, max_execution_time, post_max_size, and upload_max_filesize

    If you’re on shared hosting, then one of these values is most likely your issue.

    A few things you can try as well:

    1. Try a basic theme like Twenty Eleven

    2. Force a re-install of WP via the dashboard

  • Hakan
    • The Incredible Smush

    Hi steelerguy26,

    In addition to @digitsoft‘s suggestion of switching to the default theme:

    First of all, on front end this javascript file is missing, but this is not related to the above: http://pittsburgh-blitz.com/wp-content/themes/broadway/_inc/global.js

    On the admin side, it is possible that you have a similar issue. To figure it out, use Google Chrome, login to admin press Ctrl+Shift+J. A half page editor will appear. On the console part do you see any errors before and after trying to set featured image? If there are errors, you can find the source of the problem or copy here and we’ll have a look.

    Also did this problem start after loading a plugin? After an update? Those answers may help.



  • steelerguy26
    • WPMU DEV Initiate

    Thanks for your input. This issue is weird because everything worked fine up until about two days ago. I have uninstalled any plugin that I though could be causing the problem and even tried to disable all plugins and still no luck.

    I am also noticing that I can’t save widgets now either. They hang on save as well. Any ideas? I am sure these issues go together.

    I made the files as suggested and here is the info is spits out.

    memory_limit = 256M

    max_execution_time = 30

    post_max_size = 64M

    upload_max_filesize = 64M

    Also I have tried the basic theme and same issue. As for a forced re-install I get:

    Downloading update from http://wordpress.org/wordpress-3.3.2-no-content.zip…

    Unpacking the update…

    Verifying the unpacked files…

    Installing the latest version…

    Could not copy file.: /home/pittsbur/public_html/wp-admin/admin-ajax.php

    Installation Failed

  • Hakan
    • The Incredible Smush

    This is not normal: Could not copy file.: /home/pittsbur/public_html/wp-admin/admin-ajax.php

    Can it be a limitation from your hosting? Maybe upload limit, storage limit?

    Try to download WordPress from wordpress.org and manually update using FTP. If this doesn’t help, you’d rather consult to your hosting.

  • steelerguy26
    • WPMU DEV Initiate


    I tried the Google Chrome suggestion but to be honest I am not really sure what I am looking for.

    Also I believe it started after a couple updates to plugins but I am not sure which ones to be honest. I did try to disable all plugins and it did not help though. I wish I knew enough about this stuff to figure it out but everything I have tried has changed nothing.

  • steelerguy26
    • WPMU DEV Initiate

    I am wondering if it could be a hosting issue as well but I have had the same package with them for like 4 years and never had an issue before like this. I have a reseller account via Hostgator. I have check other sites I have on the same hosting account and don’t have this issue with any of theme.

    Also I already tried to download an updated wordpress and re-upload via FTP before coming here and it did not help either.

  • digitsoft
    • The Crimson Coder

    Oh…you’re on a shared box, so you’re stuck with what they give you. On a vps or dedicated box you can do it, but this is what you need (proftpd) to fix your issue. I guess you could always chat with HG and see if there’s a way to get proftpd somewhere on a shared box.

    If you’re just running one site, then ask HG how to fix this issue (it’s pureftp that causes this). If you’re running multiple sites, then save yourself a lot of grief and get a vps with cPanel/WHM ($40-50/mo).

  • steelerguy26
    • WPMU DEV Initiate

    HG Tech support fixed the issue. Thanks for all your help guys.

    “Yes, I checked in the cPanel’s error log section and did see one of the errors was with themes directory and permissions, so I ran permissions fixing process to set them to default, and since then no additional errors I see listed in the log.”

  • digitsoft
    • The Crimson Coder

    Glad they fixed it! You are running Pureftpd…just checked.

    Anyway…for anyone reading this in the future – if you have similar problems and permissions don’t fix it, change to proftpd if you have the option to prevent this and many other issues.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.