Few Issues with Appointments+

Hi,

I put this in the area when I granted support access, but figure I'd put it in a ticket for me to be able to see later. One thing I just noticed b/c this dev environment is on Hostgator, who sucks, is php is 5.4.45. I see this issue error message too when I click on the WPMU Dev>System Info button:

Warning: mysqli_get_server_info() expects parameter 1 to be mysqli, resource given in /home4/kory27/islandview/wp-content/plugins/wpmudev-updates/template/part-system-info.php on line 77.

I'm upgrading to php 7 now. Didn't see that before. Thx.

I am having several issues with Appointments+. Just a heads up, bc it may help you fix it, when I installed I guess I installed the free version by accident. Then when I upgraded the installation initially failed b/c the folder existed. I then deactivated/deleted the free version and it installed fine.

My issues are:

When I try to save in Appointments>Setting>Display, and other areas, I get this message:

Warning: is_a() expects parameter 2 to be string, object given in /home4/kory27/islandview/wp-content/plugins/appointments/admin/pages/class-admin-settings-page.php on line 323

Warning: Cannot modify header information - headers already sent by (output started at /home4/kory27/islandview/wp-content/plugins/appointments/admin/pages/class-admin-settings-page.php:323) in /home4/kory27/islandview/wp-includes/pluggable.php on line 1210

It stills saved, for instance, display color, but I got that message.

On the other hand, I changed the Working from No to Yes on Saturday, and it saved, but my calendar still shows as "not possible" on my page http://islandview.rabbitholeconsulting.com/rent-a-kayak-at-island-view-waterfront-cafe/

My next question may actually me not understanding the configuration, but I set the capacity of my kayak rentals, I have 4 types, to how many each hour could be rented. But, when I even just have 1 pending appt., for instance I don't finish the checkout process, it still turns it to status "busy"/red on the appt. calendar. When I delete the pending appt. it goes back to blue. My question:

1. Do I need to create the number of service providers for each type of services, i.e. 4 service providers (kayaks), if I want to be able to rent 4 of them each hour (or whatever service).
2. How can I get the pending to not reflect in the reserved number b/c until they pay I don't care.

Thanks!

    Ash

    Hello Kory

    About the Dashboard plugin, I believe it is php version issue. Let us know how it works with php7.

    Let's get to the appointments issues:

    Warning: is_a() expects parameter 2 to be string, object given in /home4/kory27/islandview/wp-content/plugins/appointments/admin/pages/class-admin-settings-page.php on line 323

    I can confirm this in my site, so I am marking this as a bug and reporting to the developer. For now, please go to /wp-content/plugins/appointments/admin/pages/class-admin-settings-page.php line no 323 and replace

    $is_dummy = is_a( 'Appointments_Worker', $worker ) && $worker->is_dummy();

    with

    $is_dummy = is_a( $worker, 'Appointments_Worker' ) && $worker->is_dummy();

    On the other hand, I changed the Working from No to Yes on Saturday, and it saved, but my calendar still shows as "not possible" on my page http://islandview.rabbitholeconsulting.com/rent-a-kayak-at-island-view-waterfront-cafe/

    You need to set the working hours for the provider. I have made the changes, please check now.
    What I did is, went to Dashboard > Appointments > Settings > Working Hours > List for: > Selected Island View Kayak Rental and then selected YES for Saturday.

    Do I need to create the number of service providers for each type of services, i.e. 4 service providers (kayaks), if I want to be able to rent 4 of them each hour (or whatever service).

    You can handle that with one service provider. If you can server 4 persons at the same time, then just set the capacity four. If you have four different services and want to ser 4 services at the same time, then you have to create four providers.

    How can I get the pending to not reflect in the reserved number b/c until they pay I don't care.

    This is actually done if the user selects a lot but could not pay at that time due to power problem or server issue, so he can come back and make the payment. After certain time if the user doesn't come back, the slot will be removed automatically. You can control the time from Appointments > Settings > General > Time > Disable pending appointments after (mins) section.

    Hope it helps! Please feel free to ask more questions if you have any.

    Have a nice day!

    Cheers,
    Ash