Few questions about the Social Theme

Hello.

I've just installed the social theme.
I have a few questions:

My forum looks "different". There is something wrong with it, I tried to fix it myself but with no success.
Here is the picture for your reference.
http://imageshack.us/photo/my-images/202/85693530.jpg/

I'd like to change the color of my buttons to have only one color instead of gradient.

How can I customize the header menu links for logged in users? the one with "Welcome back.."? I'd like to add, edit and delete some links.

Is it possible to change the position of search widget? I'd like to place it next to the main menu.

  • PC
    • WPMU DEV Initiate

    My forum looks "different". There is something wrong with it, I tried to fix it myself but with no success.
    Here is the picture for your reference.
    http://imageshack.us/photo/my-images/202/85693530.jpg/

    Looks like you have buddypress installed, shouldn't you be using buddypress in built forums as that would look better.

    I'd like to change the color of my buttons to have only one color instead of gradient.

    Just Edit the CSS

    remove the code

    background: -moz-linear-gradient(top, white 0%, #D6177F 99%) !important;

    and replace it with

    `background: #D6177F;'

    You can choose any color which you like :slight_smile:

    This is how it will look

    How can I customize the header menu links for logged in users? the one with "Welcome back.."? I'd like to add, edit and delete some links.

    You can use our Ultimate Branding Plugin : https://premium.wpmudev.org/project/ultimate-branding/ to do that.

    Is it possible to change the position of search widget? I'd like to place it next to the main menu.

    That is something which would need a custom code as this theme does not support header widgets so you will have to change the code to achieve that.

    Cheers, PC

  • PC
    • WPMU DEV Initiate

    Hello @Kerpal

    Greetings and thanks for your post.

    I am looking into this for you and will post soon. I hope my previous response helped ? I already included the css you need to change to change the color of the buttons !

    If that was not helpful, I will be posting it in a more simple way.

    Thanks

  • Laprek
    • Design Lord, Child of Thor

    Hi PC.

    Thank you for your response.

    Yes, you have included the two lines of the css file I need to change but I don't know which file should I modify. What's the name of the file? I tried with style.css but that's not the one I think.

    And in regards to the buddypress forums - I tried to use buddypress with other themes and everything worked fine. It seems to be an issue with Buddypress Social theme.

    Thank you!

  • PC
    • WPMU DEV Initiate

    Hello @Kerpal

    Thanks for writing back

    The best way to do it is install a plugin http://wordpress.org/extend/plugins/imporved-simpler-css/ and activate it.

    Then go to Appearance >> Custom CSS and add the below code to the CSS

    button, a.button, input[type="submit"], input[type="button"], input[type="reset"], ul.button-nav li a, div.generic-button a, .comment-reply-link, input.button, input.submit, #custom ul#nav li#current_user a, button:hover, a.button:hover, a.button:focus, input[type="submit"]:hover, input[type="button"]:hover, input[type="reset"]:hover, ul.button-nav li a:hover, ul.button-nav li.current a, div.generic-button a:hover, .comment-reply-link:hover
    
    {background : red !important }

    Choose any color of your choice or use a color code with a hash eg #fffff in place of red

    I have tested it live here : http://wpdemo.in/

    And in regards to the buddypress forums - I tried to use buddypress with other themes and everything worked fine. It seems to be an issue with Buddypress Social theme.

    Are you using Group Forums or Sitewide Forums ? Please advise so that I can test that on my lab site to replicate the issue.

    Cheers, PC

  • PC
    • WPMU DEV Initiate

    Hey Kerpal,

    Greetings and I am glad I could help :slight_smile: Please let me know how that goes.

    I'm using Sitewide Forums.

    I will do a few tests on that one, if you feel I am taking more time please feel free to nag me :wink: :slight_smile:

    Cheers, PC

  • Laprek
    • Design Lord, Child of Thor

    Hello PC.

    This Plugin is great! Thank you!
    I have managed to fix my buddypress forums.

    The code you gave me doesn't work :slight_frown: But I think I'll leave it for now.

    I'd like to ask you one more thing.
    I need to import all data (users, avatars, passwords, forums, topics, replies) from oxwall (social networking software) to buddypress.
    Would you know how to do that?

    Cheers!

  • PC
    • WPMU DEV Initiate

    Hello @Kerpal

    Greetings and thanks for writing back.

    The code you gave me doesn't work :slight_frown: But I think I'll leave it for now.

    If you want I can take a closer look on that for you ?

    I'd like to ask you one more thing.
    I need to import all data (users, avatars, passwords, forums, topics, replies) from oxwall (social networking software) to buddypress.
    Would you know how to do that?

    I am afraid, no :slight_frown: I have not used Oxwall, I think the best place should be the Oxwall support forums to get a good answer to this one.. I will still look for more info and will let you know as I come across anything :slight_smile:

    Cheers, PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.