First, thanks for the forum as always. You guys are great.

First, thanks for the forum as always. You guys are great.

My question relates to SSL and WPMU. I posted several threads about this issue, but I wanted to post one more about the “big picture”. I really like WPMU for obvious reasons (consolidated management, advertising across admin, messaging, tickets, branding, etc, etc.)

The chink in the proverbial armor are SSL’s. I thought I did my homework when selecting an SSL (UCC SSL) on PLESK. I’ve added the SSL’s and everything was seemingly going great. If I ran a test (just a file non-related to WPMU sites), it would worked great. The https also works perfectly with the main site install.

BUT then I tried the actual client’s site (domain mapped) and it keeps flipping back to http protocol. I tried to use the force https WordPress plugin but it threw me in a loop (my guess is jumping between http and https) when I used the mapped TLD. The plugin did nothing when I used the subdomain path. Tried resetting the htacess file per another thread as well. Nothing seems to work.

The only X-factor I can conclude is the sites that don’t accept the https that are the add-on domains that don’t have physical hosting assigned in PLESK.

I have given up on the battle of trying to get the SSL to work with WPMU FOR NOW, but I can’t help but think that I am not the first guy to run across this issue.

I will drop WooCommerce like a hot potato if I can get a consolidated solution (Woo admitted their force secure option doesn’t work with WPMU even though they say they run their demos in WPMU – figure that one out…:wink: :slight_smile:

The SSL in general is not specific to woocommerce however, because any attempts to use https on ANY page jumps me back to http.

Let’s face it, the “Woo” products are great, but the only thing those guys supported lately for us was decreasing their lifetime support to 2 years to assure, “they will still be around”. Their support comes with a healthy dose of sarcastic humble pie which is great for anyone frustrated trying to figure out a problem (okay, that was my sarcasm…:wink:

So as of now, I am planning on doing a late night session to pull two sites that I REALLY want to keep in WPMU on a separate install. This thread is my hail mary pass before I do that tonight hoping someone has a good suggestion (by the way, looks like SNAPSHOT may save me tons of time… thanks).

Here is what I am wondering:

Since my addons don’t have official hosting in PLESK, is PLESK causing the issue using domain mapping or is it something else preventing the HTTPS? Is it a config issues in PLESK itself?

Does PLESK require a physical hosting package attached to a domain in order to allow HTTPS?

If its not, then why does WPMU sites force the public http, but standalone files in the root allow for https?

Are UCC SSL’s the right type of SSL? My inquiries with other entities implied it was. If not, what type of SSL is best? Maybe I received some bad consultation?

Since WooCommerce can’t help, what I would LOVE to do is keep everything native to install and use something like the WordPress plugin to force HTTPS on the pages inside the cart directory (path), but first I have to get the site to allow https in general.

Here’s is what I am using for our server: PLESK, LAMP, Subdomain setup in WPMU, UCC SSL. Pretty much the Happy Meal of hosting combinations.

There are no conflicts with plugins or anything to force the loop to http and not allow the https. I read several forums state this could be it with other inquiries, but its not related in my case at least. I checked the global plugins as well as the local ones?

Again, I appreciate your help. My other threads seem to indicate that https should doable… but no one has given me he aha moment yet. This is my home base for this issue moving forward.

I am honestly hoping I am doing something dumb. I welcome dumb… good for the soul and offers easy fixes.