Popup pro has errors after install, rest of wordpress working fine

First, upon installation and every view of a popup pro admin screen, i have an error showing at the top of the popup pro admin screen. Screen shot attached.

Then I spent like 30 minutes crafting the perfect popup, text, animation and image to make my first popup, getting it just right, and though the previews sometimes acted strangely, i finally got one I liked and hit save. The spinner spun, and landed me on a page saying a single line that I did not have permission to edit this record. EVERY other part of my wordpress system works just fine, so this is definitely a popup pro incompatibility of some sort.

How can I trust this plugin? Why cant I save a popup? Whats with the error message in the screenshot?

I really want to use as many wpmudev plugins as possible, since I pay for them, but I keep finding them buggy or slow or inadequate compared to other options, often free, and that frustrates me. What can we do here about these errors?

  • Adam Czajczyk

    Hello Corky,

    I hope you're well today and thank you for your question!

    I've visited your site's dashboard using a support access that you granted and reviewed its settings. The error you're referring to comes from WPMU DEV Dashboard integration that's built in into all our plugins and is meant to e.g. notify you about updates or special requirements for some plugins.

    The error indicates that the script "timed out" meaning it wasn't able to complete its work within a timeframe allowed by PHP. There's 66 active plugins on your site and they all consume resources. Your WordPress however is limiting these resources. That said, I think we should start with basic memory tweak here. Please add following line to your "wp-config.php" file:

    define('WP_MEMORY_LIMIT' , '256M');

    The line should be placed above the "/*That's all. Stop editing...." line and will allow WordPress (therefore its plugins as well) use all the memory allowed by PHP configuration. This should also affect overall site performance.

    Let me know please if it helped.
    Best regards,
    Adam

  • corky

    Ah well that's a handy config setting. As you could see, I've already tweaked apache and php to allow more memory and I know Im plug in heavy, but through optimization, caching and a cdn, I still get .8 second home page loads on gtmetrix and in a browser. It's really only slow in admin even without object caching.

    My biggest issue was the error message you explained so well, and the fact that after working hard on the post for 30 minutes, popup pro informed me I didnt have permission to save it, which was weird, because I WAS logged in and other "saves" in other plugins worked right after that error.

    Anyway, Ive applied your memory tweak and thats helpful as heck. thank you!

  • Adam Czajczyk

    Hello Corky!

    I just took another look at your setup and I think there are two more settings worth tweaking in case of your setup. That'd be PHP settings for

    - "max_execution_time" which is set to 60 seconds and I'd recommend making it 120-150 seconds
    - "post_max_size" which is st to 8M , I'd suggest 32M

    This options should also affect site's performance a bit.

    Kind regards,
    Adam