Foldernaming scheme of WPMUDEV Plugins using always wpmudev-plugin-name

Hi All

As we tested all currently available wpmudev plugin in one test site we came along some problems and one of them popped up when we installed and checked ad-widget with defender.

It gave us a vulnerability warning because it was mixing up the name with the vulnerable wordpress-ad-widget and even suggested to update to another actual vulnerable version of that plugin.

To solve that problem we simply renamed the plugin folder from

ad-widget - which same as the wordpress-ad-widget is using
to
wpmudev-ad-widget which worked just perfect

A 5 minute change

But while we checked for that problem we realized that WPMUDEV seems to have no clue how useful a naming convention could be for developers and site maintainers.

Therefore I suggest that all WPMUDEV plugins will be stored in a wpmudev-plugin-name folder

They would appear as a wpmudev block in the plugins folder
They would be much better visible also in maintenance work
They would have a CI (Corporate Identity) and would promote WPMUDEV like a Daimler who stands for high quality (even sometimes they break down like any other car ;-()

many plugins already follow that naming scheme:
IMPORTANT use always hyphen and not the underscore and always write wpmudev and NOT wpmu-dev

lets start from the back

wpmudev-videos
wpmudev-updates
wpmudev-ad-widget <- ad-widget
wpmudev-maps <- wpmu_dev_maps_plugin
wpmudev-seo <- wpmu-dev-seo
wpmudev-post-votes <- wpmu-dev-post-votes
wpmudev-smush-pro <- wp-smush-pro
wpmudev-hummingbird <- wp-hummingbird
wpmudev-defender <- wp-defender
wpmudev-chat <- wordpress-chat
wpmudev-user-widget <- users-widget
wpmudev-user-sync <- user-sync
wpmudev-user-reports <- user-reports
wpmudev-user-activity <- user-activity
wpmudev-upfront-builder <- upfront-builder
wpmudev- ...

If you like a shorter prefix for all wpmudev plugins use one which is unique and one which starts with w (as it gathers all plugins at the end (z would be even better)

It would take about one week to change all those plugin paths, probably even only a weekend - like a code sprint weekend where members could help to have afterward a much cleaner working surrounding!

Kind regards
Andi